Bench error on upgrade to 7.1

Hello all, I am trying to upgrade my 7.0.x to 7.1 this morning and am getting an error. Here are the commands I have run.

$ bench use site1-test.local
$ bench update --upgrade
INFO:bench.utils:updating bench
Already up-to-date.
Requirement already satisfied (use --upgrade to upgrade): Pillow in ./env/lib/python2.7/site-packages frappe
 * branch            master     -> FETCH_HEAD
Updating 9def17f..25608cc
error: Your local changes to the following files would be overwritten by merge:
	... lots of files listed ...
Traceback (most recent call last):
  File "/usr/local/bin/bench", line 11, in <module>
    load_entry_point('bench', 'console_scripts', 'bench')()
  File "/home/erpnext/.bench/bench/", line 40, in cli
  File "/usr/local/lib/python2.7/dist-packages/click/", line 716, in __call__
    return self.main(*args, **kwargs)
  File "/usr/local/lib/python2.7/dist-packages/click/", line 696, in main
    rv = self.invoke(ctx)
  File "/usr/local/lib/python2.7/dist-packages/click/", line 1060, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/usr/local/lib/python2.7/dist-packages/click/", line 889, in invoke
    return ctx.invoke(self.callback, **ctx.params)
  File "/usr/local/lib/python2.7/dist-packages/click/", line 534, in invoke
    return callback(*args, **kwargs)
  File "/home/erpnext/.bench/bench/commands/", line 60, in update
    _update(pull, patch, build, bench, auto, restart_supervisor, requirements, no_backup, upgrade, force=force)
  File "/home/erpnext/.bench/bench/commands/", line 76, in _update
  File "/home/erpnext/.bench/bench/", line 140, in pull_all_apps
    remote=remote, branch=get_current_branch(app, bench_path=bench_path)), cwd=app_dir)
  File "/home/erpnext/.bench/bench/", line 127, in exec_cmd
    raise CommandFailedError(cmd)
bench.utils.CommandFailedError: git pull  upstream master

I have looked at a collection of other posts where others get the same error. I’ll admit I was using sudo at first, this error is still coming up after I have reset file permissions on the directories, did a git reset --hard and git pull from the ~/.bench directory, etc.

I have two sites on my server, run running on regular port 80 (site1.local) and then a test/non-prod site called site1-test.local running on port 8080. I am trying to update just the test site to start if possible, but either way still seem to get the error.

What I find interesting is bench aborts before it has finished listing all the files it is going to update. I have not altered any of the files by hand and I am pulling master branch.


Can you go to the apps/frappe folder and run git status and post the result?

Here you go

$ git status
On branch master
Your branch is behind 'upstream/master' by 332 commits, and can be fast-forwarded.
  (use "git pull" to update your local branch)
Changes not staged for commit:
  (use "git add <file>..." to update what will be committed)
  (use "git checkout -- <file>..." to discard changes in working directory)

        modified:   .gitignore
        modified:   .travis.yml

  ... lots and lots of rows that say modified: [file name] ...

        modified:   socketio.js
        modified:   test_sites/apps.txt
        modified:   test_sites/languages.txt
        modified:   test_sites/test_site/site_config.json

no changes added to commit (use "git add" and/or "git commit -a")


I’m not an expert, but maybe try git stash in that folder and run bench update again.

done and get same error. bench wants to do a lot more updates now.

more information, i went back to apps/frappe and ran the git status again and get this

$ cd apps/frappe
$ git status
On branch master
Your branch is up-to-date with 'upstream/master'.
nothing to commit, working directory clean

so i am wondering if someone is confused, bench or git as to the state of the files i have.

Can you post the exact error you get again? You might have the same issue on all your repositories (frappe, erpnext, etc)… The same git stash would fix that issue.

Thanks @Ben_Cornwell_Mott. You were spot on, i did a git status in each of the app directories and many of them had that same type of modified files list. I did a git stash on those and have re-run bench update --upgrade. I am now at the same place you are in your other thread

seems something maybe to do with the paypal integration app