Bench start issue socketio.1 | SyntaxError: Use of const in strict mode

no i didn’t

same error again come

Did you try restarting your server and then running bench start?

Welcome vijay,

The log reports this error:
11:15:04 socketio.1 | /home/js20/frappe-bench/node_modules/socket.io/node_modules/engine.io/node_modules/ws/index.js:9
11:15:04 socketio.1 | const WebSocket = require(‘./lib/WebSocket’);
11:15:04 socketio.1 | ^^^^^
11:15:04 socketio.1 | SyntaxError: Use of const in strict mode.
11:15:04 socketio.1 | at exports.runInThisContext (vm.js:73:16)
11:15:04 socketio.1 | at Module._compile (module.js:443:25)
11:15:04 socketio.1 | at Object.Module._extensions…js (module.js:478:10)
11:15:04 socketio.1 | at Module.load (module.js:355:32)
11:15:04 socketio.1 | at Function.Module._load (module.js:310:12)
11:15:04 socketio.1 | at Module.require (module.js:365:17)
11:15:04 socketio.1 | at require (module.js:384:17)
11:15:04 socketio.1 | at Server.init (/home/js20/frappe-bench/node_modules/socket.io/node_modules/engine.io/lib/server.js:119:16)

A forum search on ‘SyntaxError: Use of const in strict mode’ will give pointers to reinstall nodejs.

Hope this helps,

John

@vijay_khut Please has this issue be resolved?, i have the same problem
@clarkej i have reinstalled node.js, still having the same issue
thanks

Another search turned up reports in January that may give you pointers.

What version are you on?

What Linux environment?

@clarkej
I am using bench 4.1.10
i am using ubuntu linux 16.04

Please post the result from ‘bench version’

hi @clarkej i have attached the screen shot
i have also attached the ‘bench start’ error for further clarification

@clarkej ‘bench start’ error

ok yes that’s the bench version.

What version of erpnext and frappe are you running? To identify that, run this

frappe@ubuntu:~/frappe-bench$ bench version
erpnext 10.1.20
frappe 10.1.21

Unlike the screenshon the copy and paste from the console as you originally supplied is best since that gives the entire traceback.

i have copied and pasted
thanks

linux@nigma-Inspiron-N4030:~$ cd phestatee
linux@nigma-Inspiron-N4030:~/phestatee$ bench version
erpnext 10.1.23
frappe 10.1.23`

linux@nigma-Inspiron-N4030:~$ cd phestatee
linux@nigma-Inspiron-N4030:~/phestatee$ bench start
08:20:21 system | redis_socketio.1 started (pid=3766)
08:20:21 system | redis_queue.1 started (pid=3771)
08:20:21 system | schedule.1 started (pid=3772)
08:20:21 system | watch.1 started (pid=3773)
08:20:21 system | worker_long.1 started (pid=3768)
08:20:21 redis_socketio.1 | 3770:M 20 Apr 08:20:21.338 * Increased maximum number of open files to 10032 (it was originally set to 1024).
08:20:21 redis_socketio.1 | .
08:20:21 redis_socketio.1 | .-__ ''-._ 08:20:21 redis_socketio.1 | _.- . . ‘’-._ Redis 3.0.6 (00000000/0) 64 bit
08:20:21 redis_socketio.1 | .- .-```. ```\/ _.,_ ''-._ 08:20:21 redis_socketio.1 | ( ' , .-` | `, ) Running in standalone mode 08:20:21 redis_socketio.1 | |`-._`-...-` __...-.-.|'_.-'| Port: 12000 08:20:21 redis_socketio.1 | | -. ._ / _.-' | PID: 3770 08:20:21 redis_socketio.1 | -._ -._ -./ .-’ .-’
08:20:21 redis_socketio.1 | |-._-.
-.__.-' _.-'_.-'| 08:20:21 redis_socketio.1 | | -.
-._ _.-'_.-' | http://redis.io 08:20:21 redis_socketio.1 | -._ -._-..-'.-’ .-’
08:20:21 redis_socketio.1 | |-._-.
-.__.-' _.-'_.-'| 08:20:21 redis_socketio.1 | | -.
-._ _.-'_.-' | 08:20:21 redis_socketio.1 | -._ -._-.
.-‘.-’ .-’
08:20:21 redis_socketio.1 | -._ -..-’ _.-’
08:20:21 redis_socketio.1 | -._ _.-' 08:20:21 redis_socketio.1 | -.
.-’
08:20:21 redis_socketio.1 |
08:20:21 redis_socketio.1 | 3770:M 20 Apr 08:20:21.339 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
08:20:21 redis_socketio.1 | 3770:M 20 Apr 08:20:21.339 # Server started, Redis version 3.0.6
08:20:21 redis_socketio.1 | 3770:M 20 Apr 08:20:21.339 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
08:20:21 redis_socketio.1 | 3770:M 20 Apr 08:20:21.339 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
08:20:21 redis_socketio.1 | 3770:M 20 Apr 08:20:21.346 * The server is now ready to accept connections on port 12000
08:20:21 redis_queue.1 | 3778:M 20 Apr 08:20:21.345 * Increased maximum number of open files to 10032 (it was originally set to 1024).
08:20:21 redis_queue.1 | .
08:20:21 redis_queue.1 | .-__ ''-._ 08:20:21 redis_queue.1 | _.- . . ‘’-.
Redis 3.0.6 (00000000/0) 64 bit
08:20:21 redis_queue.1 | .- .-```. ```\/ _.,_ ''-._ 08:20:21 redis_queue.1 | ( ' , .-` | `, ) Running in standalone mode 08:20:21 redis_queue.1 | |`-._`-...-` __...-.-.
|’_.-'| Port: 11000 08:20:21 redis_queue.1 | | -._ ._ / _.-' | PID: 3778 08:20:21 redis_queue.1 | -._ -._ -./ .-’ .-’
08:20:21 redis_queue.1 | |-._-.
-.__.-' _.-'_.-'| 08:20:21 redis_queue.1 | | -.
-._ _.-'_.-' | http://redis.io 08:20:21 redis_queue.1 | -._ -._-..-'.-’ .-’
08:20:21 redis_queue.1 | |-._-.
-.__.-' _.-'_.-'| 08:20:21 redis_queue.1 | | -.
-._ _.-'_.-' | 08:20:21 redis_queue.1 | -._ -._-.
.-‘.-’ .-’
08:20:21 redis_queue.1 | -._ -..-’ _.-’
08:20:21 redis_queue.1 | -._ _.-' 08:20:21 redis_queue.1 | -.
.-’
08:20:21 redis_queue.1 |
08:20:21 redis_queue.1 | 3778:M 20 Apr 08:20:21.346 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
08:20:21 redis_queue.1 | 3778:M 20 Apr 08:20:21.346 # Server started, Redis version 3.0.6
08:20:21 redis_queue.1 | 3778:M 20 Apr 08:20:21.346 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
08:20:21 redis_queue.1 | 3778:M 20 Apr 08:20:21.346 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
08:20:21 redis_queue.1 | 3778:M 20 Apr 08:20:21.346 * The server is now ready to accept connections on port 11000
08:20:21 system | web.1 started (pid=3776)
08:20:21 system | worker_default.1 started (pid=3785)
08:20:21 system | socketio.1 started (pid=3797)
08:20:21 socketio.1 | /bin/sh: 1: /usr/bin/node: not found
08:20:21 system | socketio.1 stopped (rc=127)
08:20:21 system | redis_cache.1 started (pid=3798)
08:20:21 redis_cache.1 | 3801:M 20 Apr 08:20:21.405 * Increased maximum number of open files to 10032 (it was originally set to 1024).
08:20:21 redis_cache.1 | .
08:20:21 redis_cache.1 | .-__ ''-._ 08:20:21 redis_cache.1 | _.- . . ‘’-.
Redis 3.0.6 (00000000/0) 64 bit
08:20:21 redis_cache.1 | .- .-```. ```\/ _.,_ ''-._ 08:20:21 redis_cache.1 | ( ' , .-` | `, ) Running in standalone mode 08:20:21 redis_cache.1 | |`-._`-...-` __...-.-.
|’_.-'| Port: 13000 08:20:21 redis_cache.1 | | -._ ._ / _.-' | PID: 3801 08:20:21 redis_cache.1 | -._ -._ -./ .-’ .-’
08:20:21 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 08:20:21 redis_cache.1 | | -.
-._ _.-'_.-' | http://redis.io 08:20:21 redis_cache.1 | -._ -._-..-'.-’ .-’
08:20:21 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 08:20:21 redis_cache.1 | | -.
-._ _.-'_.-' | 08:20:21 redis_cache.1 | -._ -._-.
.-‘_.-’ _.-’
08:20:21 redis_cache.1 | -._ -..-’ _.-’
08:20:21 redis_cache.1 | -._ _.-' 08:20:21 redis_cache.1 | -.
.-’
08:20:21 redis_cache.1 |
08:20:21 redis_cache.1 | 3801:M 20 Apr 08:20:21.406 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
08:20:21 redis_cache.1 | 3801:M 20 Apr 08:20:21.406 # Server started, Redis version 3.0.6
08:20:21 redis_cache.1 | 3801:M 20 Apr 08:20:21.406 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
08:20:21 redis_cache.1 | 3801:M 20 Apr 08:20:21.406 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
08:20:21 redis_cache.1 | 3801:M 20 Apr 08:20:21.406 * The server is now ready to accept connections on port 13000
08:20:21 system | worker_short.1 started (pid=3805)
08:20:21 system | sending SIGTERM to redis_socketio.1 (pid 3766)
08:20:21 system | sending SIGTERM to worker_long.1 (pid 3768)
08:20:21 system | sending SIGTERM to watch.1 (pid 3773)
08:20:21 system | sending SIGTERM to redis_queue.1 (pid 3771)
08:20:21 system | sending SIGTERM to web.1 (pid 3776)
08:20:21 system | sending SIGTERM to schedule.1 (pid 3772)
08:20:21 system | sending SIGTERM to worker_default.1 (pid 3785)
08:20:21 system | sending SIGTERM to redis_cache.1 (pid 3798)
08:20:21 system | sending SIGTERM to worker_short.1 (pid 3805)
08:20:21 redis_socketio.1 | 3770:signal-handler (1524212421) Received SIGTERM scheduling shutdown…
08:20:21 redis_socketio.1 | 3770:M 20 Apr 08:20:21.455 # User requested shutdown…
08:20:21 redis_socketio.1 | 3770:M 20 Apr 08:20:21.455 # Redis is now ready to exit, bye bye…
08:20:21 system | redis_socketio.1 stopped (rc=-15)
08:20:21 redis_queue.1 | 3778:signal-handler (1524212421) Received SIGTERM scheduling shutdown…
08:20:21 system | web.1 stopped (rc=-15)
08:20:21 system | worker_default.1 stopped (rc=-15)
08:20:21 redis_cache.1 | 3801:signal-handler (1524212421) Received SIGTERM scheduling shutdown…
08:20:21 system | worker_long.1 stopped (rc=-15)
08:20:21 system | schedule.1 stopped (rc=-15)
08:20:21 system | watch.1 stopped (rc=-15)
08:20:21 system | worker_short.1 stopped (rc=-15)
08:20:21 redis_cache.1 | 3801:M 20 Apr 08:20:21.509 # User requested shutdown…
08:20:21 redis_cache.1 | 3801:M 20 Apr 08:20:21.509 # Redis is now ready to exit, bye bye…
08:20:21 system | redis_cache.1 stopped (rc=-15)
08:20:21 redis_queue.1 | 3778:M 20 Apr 08:20:21.553 # User requested shutdown…
08:20:21 redis_queue.1 | 3778:M 20 Apr 08:20:21.553 # Redis is now ready to exit, bye bye…
08:20:21 system | redis_queue.1 stopped (rc=-15)

Blockquote

So you are current with this the problem:

08:20:21 socketio.1 | /bin/sh: 1: /usr/bin/node: not found

I think you can safely ignore the WARNING notes.

Maybe just a path problem?

frappe@ubuntu:~/frappe-bench$ whereis node
node: /usr/bin/node /usr/include/node /usr/share/man/man1/node.1.gz

frappe@ubuntu:~/frappe-bench$ node --version
v6.13.1

frappe@ubuntu:~/frappe-bench$ npm --version
3.10.10

I suggest this first:

sudo apt-get update
sudo apt-get upgrade

then run this:

 bench setup requirements

hello @clarkej sorry problem is still present
i ran the commands as shown

linux@nigma-Inspiron-N4030:~$ cd phestatee
linux@nigma-Inspiron-N4030:~/phestatee$ whereis node
node: /usr/bin/node /usr/local/bin/node /usr/include/node /usr/share/man/man1/node.1.gz
linux@nigma-Inspiron-N4030:~/phestatee$ node --version
v9.10.1
linux@nigma-Inspiron-N4030:~/phestatee$ npm --version
5.6.0
linux@nigma-Inspiron-N4030:~/phestatee$ sudo apt-get update
[sudo] password for linux:
Sorry, try again.
[sudo] password for linux:
Get:1 Index of /ubuntu xenial-security InRelease [102 kB]
Hit:2 Index of /ubuntu xenial InRelease
Get:3 Index of /ubuntu xenial-updates InRelease [102 kB]
Get:4 Index of /ubuntu xenial-security/main amd64 DEP-11 Metadata [67.4 kB]
Get:5 Index of /ubuntu xenial-backports InRelease [102 kB]
Get:6 Index of /ubuntu xenial-security/main DEP-11 64x64 Icons [77.2 kB]
Get:7 Index of /ubuntu xenial-security/universe amd64 DEP-11 Metadata [107 kB]
Get:8 Index of /ubuntu xenial-security/universe DEP-11 64x64 Icons [147 kB]
Get:9 Index of /ubuntu xenial-updates/main amd64 Packages [757 kB]
Hit:10 https://deb.nodesource.com/node_9.x xenial InRelease
Get:11 Index of /mirror/mariadb/repo/10.2/ubuntu/ xenial InRelease [3,871 B]
Get:12 Index of /ubuntu xenial-updates/main i386 Packages [701 kB]
Get:13 Index of /ubuntu xenial-updates/main amd64 DEP-11 Metadata [319 kB]
Get:14 Index of /ubuntu xenial-updates/main DEP-11 64x64 Icons [231 kB]
Get:15 Index of /ubuntu xenial-updates/universe amd64 Packages [621 kB]
Err:15 Index of /ubuntu xenial-updates/universe amd64 Packages
Hash Sum mismatch
Get:16 Index of /ubuntu xenial-updates/universe i386 Packages [574 kB]
Err:16 Index of /ubuntu xenial-updates/universe i386 Packages

Get:17 Index of /ubuntu xenial-updates/universe amd64 DEP-11 Metadata [242 kB]
Get:18 Index of /ubuntu xenial-updates/universe DEP-11 64x64 Icons [328 kB]
Get:19 Index of /ubuntu xenial-updates/multiverse amd64 DEP-11 Metadata [5,972 B]
Get:20 Index of /ubuntu xenial-backports/main amd64 DEP-11 Metadata [3,328 B]
Get:21 Index of /ubuntu xenial-backports/universe amd64 DEP-11 Metadata [5,088 B]
Fetched 4,496 kB in 16s (274 kB/s)
Reading package lists… Done
E: Failed to fetch http://ci.archive.ubuntu.com/ubuntu/dists/xenial-updates/universe/binary-amd64/by-hash/SHA256/97f43b37c38b4462095d537005cf9b8cf69a489e60f6a73ef22b5ac162c162ac Hash Sum mismatch
E: Failed to fetch http://ci.archive.ubuntu.com/ubuntu/dists/xenial-updates/universe/binary-i386/by-hash/SHA256/4306ba4997ebfd84fb005ba372b0ff44e9d3d625e095dee9a5bd2edc0bb288e5
E: Some index files failed to download. They have been ignored, or old ones used instead.
linux@nigma-Inspiron-N4030:~/phestatee$ sudo apt-get upgrade
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
The following packages will be upgraded:
libssl1.0.0 openssl snapd ubuntu-core-launcher
4 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 15.3 MB of archives.
After this operation, 2,576 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 Index of /ubuntu xenial-security/main amd64 libssl1.0.0 amd64 1.0.2g-1ubuntu4.12 [1,085 kB]
Get:2 Index of /ubuntu xenial-updates/main amd64 ubuntu-core-launcher amd64 2.32.3.2 [1,566 B]
Get:3 Index of /ubuntu xenial-updates/main amd64 snapd amd64 2.32.3.2 [13.7 MB]
Get:4 Index of /ubuntu xenial-security/main amd64 openssl amd64 1.0.2g-1ubuntu4.12 [492 kB]
Fetched 15.3 MB in 39s (390 kB/s)
Preconfiguring packages …
(Reading database … 218622 files and directories currently installed.)
Preparing to unpack …/ubuntu-core-launcher_2.32.3.2_amd64.deb …
Unpacking ubuntu-core-launcher (2.32.3.2) over (2.29.4.2) …
Preparing to unpack …/snapd_2.32.3.2_amd64.deb …
Unpacking snapd (2.32.3.2) over (2.29.4.2) …
Preparing to unpack …/libssl1.0.0_1.0.2g-1ubuntu4.12_amd64.deb …
Unpacking libssl1.0.0:amd64 (1.0.2g-1ubuntu4.12) over (1.0.2g-1ubuntu4.11) …
Preparing to unpack …/openssl_1.0.2g-1ubuntu4.12_amd64.deb …
Unpacking openssl (1.0.2g-1ubuntu4.12) over (1.0.2g-1ubuntu4.11) …
Processing triggers for man-db (2.7.5-1) …
Processing triggers for libc-bin (2.23-0ubuntu10) …
Setting up snapd (2.32.3.2) …
Installing new version of config file /etc/apparmor.d/usr.lib.snapd.snap-confine.real …
snapd.snap-repair.service is a disabled or a static unit, not starting it.
Setting up ubuntu-core-launcher (2.32.3.2) …
Setting up libssl1.0.0:amd64 (1.0.2g-1ubuntu4.12) …
Setting up openssl (1.0.2g-1ubuntu4.12) …
Processing triggers for libc-bin (2.23-0ubuntu10) …
linux@nigma-Inspiron-N4030:~/phestatee$ bench setup requirements
Updating Python libraries…
INFO:bench.utils:./env/bin/pip install --upgrade pip==9.0.3
Requirement already up-to-date: pip==9.0.3 in ./env/lib/python2.7/site-packages
You are using pip version 9.0.3, however version 10.0.0 is available.
You should consider upgrading via the ‘pip install --upgrade pip’ command.
INFO:bench.utils:./env/bin/pip install -q -r /home/linux/src/frappe-bench/requirements.txt
INFO:bench.utils:./env/bin/pip install -q -r ./apps/erpnext/requirements.txt
INFO:bench.utils:./env/bin/pip install -q -r ./apps/frappe/requirements.txt
Updating node packages…
Please install yarn using below command and try again.
npm install -g yarn
linux@nigma-Inspiron-N4030:~/phestatee$ npm install -g yarn
npm WARN checkPermissions Missing write access to /usr/local/lib/node_modules
npm ERR! path /usr/local/lib/node_modules
npm ERR! code EACCES
npm ERR! errno -13
npm ERR! syscall access
npm ERR! Error: EACCES: permission denied, access ‘/usr/local/lib/node_modules’
npm ERR! { Error: EACCES: permission denied, access ‘/usr/local/lib/node_modules’
npm ERR! stack: ‘Error: EACCES: permission denied, access '/usr/local/lib/node_modules'’,
npm ERR! errno: -13,
npm ERR! code: ‘EACCES’,
npm ERR! syscall: ‘access’,
npm ERR! path: ‘/usr/local/lib/node_modules’ }
npm ERR!
npm ERR! Please try running this command again as root/Administrator.

╭─────────────────────────────────────╮
│ │
│ Update available 5.6.0 → 5.8.0 │
│ Run npm i -g npm to update │
│ │
╰─────────────────────────────────────╯

npm ERR! A complete log of this run can be found in:
npm ERR! /home/linux/.npm/_logs/2018-04-21T02_21_17_041Z-debug.log

i was required to install as root user, i granted root user to the current user with the command

then installed yarn with the command

sudo chown -R $USER /usr/local
linux@nigma-Inspiron-N4030:~/phestatee$ npm install -g yarn/usr/local/bin/yarn → /usr/local/lib/node_modules/yarn/bin/yarn.js
/usr/local/bin/yarnpkg → /usr/local/lib/node_modules/yarn/bin/yarn.js
yarn@1.6.0
added 1 package in 7.002s
linux@nigma-Inspiron-N4030:~/phestatee$

starting the bench still throws up the same error

linux@nigma-Inspiron-N4030:~/phestatee$ bench start
02:28:23 system | redis_socketio.1 started (pid=4714)
02:28:23 system | schedule.1 started (pid=4726)
02:28:23 system | worker_long.1 started (pid=4716)
02:28:23 system | worker_default.1 started (pid=4732)
02:28:23 system | redis_queue.1 started (pid=4724)
02:28:23 redis_queue.1 | 4733:M 21 Apr 02:28:23.841 * Increased maximum number of open files to 10032 (it was originally set to 1024).
02:28:23 redis_queue.1 | .
02:28:23 redis_socketio.1 | 4720:M 21 Apr 02:28:23.830 * Increased maximum number of open files to 10032 (it was originally set to 1024).
02:28:23 redis_socketio.1 | .
02:28:23 redis_socketio.1 | .-__ ''-._ 02:28:23 redis_socketio.1 | _.- . . ‘’-._ Redis 3.0.6 (00000000/0) 64 bit
02:28:23 redis_socketio.1 | .- .-```. ```\/ _.,_ ''-._ 02:28:23 redis_socketio.1 | ( ' , .-` | `, ) Running in standalone mode 02:28:23 redis_socketio.1 | |`-._`-...-` __...-.-.|'_.-'| Port: 12000 02:28:23 redis_socketio.1 | | -. ._ / _.-' | PID: 4720 02:28:23 redis_socketio.1 | -._ -._ -./ .-’ .-’
02:28:23 redis_socketio.1 | |-._-.
-.__.-' _.-'_.-'| 02:28:23 redis_socketio.1 | | -.
-._ _.-'_.-' | http://redis.io 02:28:23 redis_socketio.1 | -._ -._-..-'.-’ .-’
02:28:23 redis_socketio.1 | |-._-.
-.__.-' _.-'_.-'| 02:28:23 redis_socketio.1 | | -.
-._ _.-'_.-' | 02:28:23 redis_socketio.1 | -._ -._-.
.-‘.-’ .-’
02:28:23 redis_socketio.1 | -._ -..-’ _.-’
02:28:23 redis_socketio.1 | -._ _.-' 02:28:23 redis_socketio.1 | -.
.-’
02:28:23 redis_socketio.1 |
02:28:23 redis_socketio.1 | 4720:M 21 Apr 02:28:23.831 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
02:28:23 redis_socketio.1 | 4720:M 21 Apr 02:28:23.831 # Server started, Redis version 3.0.6
02:28:23 redis_socketio.1 | 4720:M 21 Apr 02:28:23.831 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
02:28:23 redis_socketio.1 | 4720:M 21 Apr 02:28:23.831 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
02:28:23 redis_socketio.1 | 4720:M 21 Apr 02:28:23.842 * The server is now ready to accept connections on port 12000
02:28:23 redis_queue.1 | .-__ ''-._ 02:28:23 redis_queue.1 | _.- . . ‘’-.
Redis 3.0.6 (00000000/0) 64 bit
02:28:23 redis_queue.1 | .- .-```. ```\/ _.,_ ''-._ 02:28:23 redis_queue.1 | ( ' , .-` | `, ) Running in standalone mode 02:28:23 redis_queue.1 | |`-._`-...-` __...-.-.
|’_.-'| Port: 11000 02:28:23 redis_queue.1 | | -._ ._ / _.-' | PID: 4733 02:28:23 redis_queue.1 | -._ -._ -./ .-’ .-’
02:28:23 redis_queue.1 | |-._-.
-.__.-' _.-'_.-'| 02:28:23 redis_queue.1 | | -.
-._ _.-'_.-' | http://redis.io 02:28:23 redis_queue.1 | -._ -._-..-'.-’ .-’
02:28:23 redis_queue.1 | |-._-.
-.__.-' _.-'_.-'| 02:28:23 redis_queue.1 | | -.
-._ _.-'_.-' | 02:28:23 redis_queue.1 | -._ -._-.
.-‘.-’ .-’
02:28:23 redis_queue.1 | -._ -..-’ _.-’
02:28:23 redis_queue.1 | -._ _.-' 02:28:23 redis_queue.1 | -.
.-’
02:28:23 redis_queue.1 |
02:28:23 system | web.1 started (pid=4721)
02:28:23 redis_queue.1 | 4733:M 21 Apr 02:28:23.842 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
02:28:23 redis_queue.1 | 4733:M 21 Apr 02:28:23.842 # Server started, Redis version 3.0.6
02:28:23 redis_queue.1 | 4733:M 21 Apr 02:28:23.842 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
02:28:23 redis_queue.1 | 4733:M 21 Apr 02:28:23.842 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
02:28:23 redis_queue.1 | 4733:M 21 Apr 02:28:23.842 * The server is now ready to accept connections on port 11000
02:28:23 system | watch.1 started (pid=4727)
02:28:23 system | redis_cache.1 started (pid=4736)
02:28:23 redis_cache.1 | 4752:M 21 Apr 02:28:23.865 * Increased maximum number of open files to 10032 (it was originally set to 1024).
02:28:23 redis_cache.1 | .
02:28:23 redis_cache.1 | .-__ ''-._ 02:28:23 redis_cache.1 | _.- . . ‘’-.
Redis 3.0.6 (00000000/0) 64 bit
02:28:23 redis_cache.1 | .- .-```. ```\/ _.,_ ''-._ 02:28:23 redis_cache.1 | ( ' , .-` | `, ) Running in standalone mode 02:28:23 redis_cache.1 | |`-._`-...-` __...-.-.
|’_.-'| Port: 13000 02:28:23 redis_cache.1 | | -._ ._ / _.-' | PID: 4752 02:28:23 redis_cache.1 | -._ -._ -./ .-’ .-’
02:28:23 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 02:28:23 redis_cache.1 | | -.
-._ _.-'_.-' | http://redis.io 02:28:23 redis_cache.1 | -._ -._-..-'.-’ .-’
02:28:23 redis_cache.1 | |-._-.
-.__.-' _.-'_.-'| 02:28:23 redis_cache.1 | | -.
-._ _.-'_.-' | 02:28:23 redis_cache.1 | -._ -._-.
.-‘_.-’ _.-’
02:28:23 redis_cache.1 | -._ -..-’ _.-’
02:28:23 redis_cache.1 | -._ _.-' 02:28:23 redis_cache.1 | -.
.-’
02:28:23 redis_cache.1 |
02:28:23 redis_cache.1 | 4752:M 21 Apr 02:28:23.866 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
02:28:23 redis_cache.1 | 4752:M 21 Apr 02:28:23.866 # Server started, Redis version 3.0.6
02:28:23 redis_cache.1 | 4752:M 21 Apr 02:28:23.866 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add ‘vm.overcommit_memory = 1’ to /etc/sysctl.conf and then reboot or run the command ‘sysctl vm.overcommit_memory=1’ for this to take effect.
02:28:23 redis_cache.1 | 4752:M 21 Apr 02:28:23.866 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
02:28:23 redis_cache.1 | 4752:M 21 Apr 02:28:23.866 * The server is now ready to accept connections on port 13000
02:28:23 system | worker_short.1 started (pid=4738)
02:28:23 system | socketio.1 started (pid=4737)
02:28:23 socketio.1 | /bin/sh: 1: /usr/bin/node: not found
02:28:23 system | socketio.1 stopped (rc=127)
02:28:23 system | sending SIGTERM to redis_socketio.1 (pid 4714)
02:28:23 system | sending SIGTERM to worker_long.1 (pid 4716)
02:28:23 system | sending SIGTERM to watch.1 (pid 4727)
02:28:23 system | sending SIGTERM to redis_queue.1 (pid 4724)
02:28:23 system | sending SIGTERM to web.1 (pid 4721)
02:28:23 system | sending SIGTERM to schedule.1 (pid 4726)
02:28:23 system | sending SIGTERM to worker_default.1 (pid 4732)
02:28:23 system | sending SIGTERM to redis_cache.1 (pid 4736)
02:28:23 system | sending SIGTERM to worker_short.1 (pid 4738)
02:28:23 redis_socketio.1 | 4720:signal-handler (1524277703) Received SIGTERM scheduling shutdown…
02:28:23 redis_socketio.1 | 4720:M 21 Apr 02:28:23.930 # User requested shutdown…
02:28:23 redis_socketio.1 | 4720:M 21 Apr 02:28:23.930 # Redis is now ready to exit, bye bye…
02:28:23 system | redis_socketio.1 stopped (rc=-15)
02:28:23 redis_queue.1 | 4733:signal-handler (1524277703) Received SIGTERM scheduling shutdown…
02:28:23 system | worker_long.1 stopped (rc=-15)
02:28:23 system | schedule.1 stopped (rc=-15)
02:28:23 system | worker_default.1 stopped (rc=-15)
02:28:23 system | worker_short.1 stopped (rc=-15)
02:28:23 redis_cache.1 | 4752:signal-handler (1524277703) Received SIGTERM scheduling shutdown…
02:28:23 system | watch.1 stopped (rc=-15)
02:28:23 system | web.1 stopped (rc=-15)
02:28:23 redis_cache.1 | 4752:M 21 Apr 02:28:23.974 # User requested shutdown…
02:28:23 redis_cache.1 | 4752:M 21 Apr 02:28:23.974 # Redis is now ready to exit, bye bye…
02:28:23 system | redis_cache.1 stopped (rc=-15)
02:28:24 redis_queue.1 | 4733:M 21 Apr 02:28:24.042 # User requested shutdown…
02:28:24 redis_queue.1 | 4733:M 21 Apr 02:28:24.043 # Redis is now ready to exit, bye bye…
02:28:24 system | redis_queue.1 stopped (rc=-15)
linux@nigma-Inspiron-N4030:~/phestatee$ bench setup requirements

i looked at my bench folder and saw that these two files are missing
├── :file_folder: package.json
├── :file_folder: package-lock.json
could it be the cause of the problem
thanks

@oderao

Did you followed what @clarkej
suggested?

You need to install the requirenments
as far as I understand

  • error log shows:
    linux@nigma-Inspiron-N4030:~/phestatee$ bench setup requirements

Morover you don’t need to grand root user , you just run the command as sudo.

I prefer follow this:

Thanks krnkris!

No I don’t think package.json is the problem source.

But your command shell or environment and/or Procfile is the problem?

What do you get when you run these:

frappe@ubuntu:~/frappe-bench$ grep socketio Procfile
redis_socketio: redis-server config/redis_socketio.conf
socketio: /usr/bin/node apps/frappe/socketio.js

frappe@ubuntu:~/frappe-bench$ env | grep SHELL
SHELL=/bin/bash

Maybe save a copy of your Procfile then run ‘bench setup procfile’

If bench start still fails then try this -

In Procfile change this line:

socketio: /usr/bin/node apps/frappe/socketio.js

to this:

socketio: node apps/frappe/socketio.js

Then see if the bench starts…

@clarkej thank you so much, running the “bench setup procfile” solved the problem
it replaced the old procfile and my bench is running
thanks once again,
@krnkris thanks

@clarkej thank you so much, running the “bench setup procfile” solved the problem
it replaced the old procfile and my bench is running
thanks once again,
@krnkris thanks

2 Likes

Wonderful news have fun

1 Like