Blank Login Screen After Upgrade To V8

I got blank ‘login’ screen after upgrade to v8. The upgrade ran successfully. But I cannot login to desk.

here’s browser console log:
frappe-web.min.js:659 Uncaught TypeError: Cannot read property ‘/login’ of undefined
at Object.trigger_ready (frappe-web.min.js:659)
at HTMLDocument. (frappe-web.min.js:670)
at HTMLDocument.dispatch (jquery.min.js:3)
at HTMLDocument.r.handle (jquery.min.js:3)
at Object.trigger (jquery.min.js:4)
at HTMLDocument. (jquery.min.js:4)
at Function.each (jquery.min.js:2)
at n.fn.init.each (jquery.min.js:2)
at n.fn.init.trigger (jquery.min.js:4)
at HTMLDocument. (frappe-web.min.js:669)

1 Like

have to tried clearing the cache ?

ie bench clear-cache

Without this I found a number of time I would get freezing and incomplete screens, until I had twice rebooted server. But running clear cache is the best way.

I am currently experiencing this issue after update to latest. bench clear-cache or migrate didnt help

So you say http://localhost the website home page renders as expected

But then this page is blank http://localhost/login#login

How www/ and website/ works with this is beyond me✓

Maybe check the logs for clues, and confirm you connect to the database…

I am getting exactly same error while upgrade on two Ubuntu instances.

Edit: Clearing Browser catch/cookies solved the issue


I am getting a blank screen after I click on “Login” on my new windows 10 computer not on my I Phone or older computers. I am using the ERPNEXT hosted site not one on a local server.

Hi @herb

Try clearing your browser cache and cookies. That usually resolves the issue



Hi @wale

I tried what you suggested, neither does bench clear-cache & bench migrate work

Earlier when i did bench restart, got this error, so I had to manually install, which didnt help login either.
“frappe-bench-web:frappe-bench-node-socketio: ERROR (no such file)”

I have same my console log.
Thanks all


Hi @sjc2929

Did you try rebuilding your css and js? Had a similar issue and was able to fix it that way. Please refer to the link below:

Kind regards,

Hi @wale

From the console log, seems like its the frappe-web.min.js error
“Bench update --build” did the work

Thanks a lot


Hard Refresh from browser crt+F5

1 Like

Solved. I changed from Edge Browser to Chrome.

1 Like

I am experiencing the same issue with Google Chrome as well as Firefox and Internet Explorer on Windows 10 and Mac.

The only browser which works on Windows 10 and Mac is only Safari.

I have migrated, cleared local cache as well as in bench and rebuilding css and js files… nothing works.

I am seeing this in the browser log which I can understand has something to do with cloudflare but it beats me to be sincere.

A Parser-blocking, cross site (i.e. different eTLD+1) script,, is invoked via document.write. The network request for this script MAY be blocked by the browser in this or a future page load due to poor network connectivity. If blocked in this page load, it will be confirmed in a subsequent console message.See Chrome Platform Status for more details.
(anonymous) @ login:14
login:1 Error in event handler for (unknown): TypeError: Cannot read property ‘qrstr’ of undefined
at chrome-extension://fghaphhjjindgcnpfamdgindjhiifhih/qrcode.js:113:22

Any ideas ?

If you have not done so Julian I suggest reinstall nodejs?

frappe@erpnext:~/frappe-bench$ nodejs --version
frappe@erpnext:~/frappe-bench$ node --version
frappe@erpnext:~/frappe-bench$ bench version
erpnext 8.1.1
frappe 8.1.1

Dear Clarke,
Thank you for your reply and assistance. I have just done the way you instructed but without success:

Here are the details now:

root@server2:~# nodejs --version
root@server2:~# node --version

Installed Apps

ERPNext: v8.x.x-beta (a06a600) (develop)

Frappe Framework: v8.x.x-beta (6d1c652) (develop)

I have used bench build as well as bench watch but the issue persists for the login page on Google Chrome, IE and Firefox.

I’m out of ideas haha

With respect and appreciation,

1 Like

same issue anybody here to solve the bug.

bench --site site-name clear-cache
bench build
bench restart

Clear caches in browser

Please OFF Rocket Loader if you are using Cloudflare.
i got it and solve the issue.

already tried but issue solved after Rocket Loader OFF

I managed to find the bug in my case which was a beta setting from Cloudflare that is known to have bad effects in some cases.

As soon as i disabled the setting the login page is working fine.

I hope this helps.

With respect and appreciation,