Can't access ERPNext

@william SSH to you VM and try to find out, if frappe user exists, if you used bench tool with production setup instructions it should install all necessary software dependencies without any issues for CentOS 6.X.
If frappe user does not exists on your VM, then you will need to re-run bench setup with appropriate parameters.

If you are sure, frappe exists and setup have not failed, then you should try to run following commands on SSH:

# su - frappe
$ bench new-site {your-google-cloud-fqdn} --install-app erpnext
$ bench setup nginx
$ sudo service nginx reload


Thanks for your answer.

Yes, in fact the frappe user does exist.

I did everything as you told but could not complete the last step.

I still see the main page.

@william As you can see you dont have permission to run command, either you do it from root user or add frappe user to sudoer files OR added frappe user to wheel / sudo / equivalent group.

as long as you do not reload or restart nginx, new config file generated by bench tool won’t be used and hence you will see default page.

Are you running Fedora? checkout: Home · frappe/bench Wiki · GitHub


Already ran the command as a root. But still when I refresh the page, I get the the same homepage, over and over again.

Is there anything I might be missing?

Thank you for the time, this is my first time using this.


Tried reloading/restarting the nginx server. Got no return message.

Reloaded homepage and still, ERPNext won’t appear.

Have you tried?: GitHub - frappe/bench: CLI to manage Multi-tenant deployments for Frappe apps

Check if you have correct file and path

my (standard) frappe config directory location: /home/frappe/frappe-bench/config/

config directory contains two important files nginx.conf and supervisor.conf, these two files needs to be linked under /etc/ to appropriate directory of nginx and supervisor as per OS.

if you manage to do it correctly followed by niginx reload / restart you should able to see default site by entering your GC fqdn in browser.

No luck…

I’ll keep trying and maybe get to look at some some tutorials.

I really appreciate your time @yashodhan

Hi @william

Could you post the screenshot of your nginx.conf file?



Here it is.

@yashodhan @Tanuj


I finally could install ERPNext on Google Cloud, not with CentOS 7.1 anyway. I installed it in Ubuntu and I used “the easy way” for the installation and it worked like a charm.

sudo bash --setup-production

I have to admit, I’m a bit curious as in why it didn’t work with CentOS 7.1 as it did with Ubuntu. I’ll keep trying to install it on CentOS and if i succeed I’ll come back here and post what was missing.

Thank you.

1 Like

should work with CentOS 7 as well. Maybe you missed --setup-production

Actually I did add --setup-production

On CentOS it didn’t worked and on Ubuntu it worked like a charm.

Let me try this in the evening. Maybe, it doesn’t work with Google cloud, didn’t test with that.

You can find information on this topic.

You can find information on this topic.