Can't finish "Your system is being updated. Please refresh again after a few moments"

again same problem after bench build

bench set-maintenance-mode off

Also restart bench and supervisor

1 Like

again same problem

Let’s clarify, what is the current error you receive ?

As which user did you install, and as which user are you updating? Looks like a permissions problem on some of the files, so you would probably have to do something like this…

sudo chown -R FrappeUserThatYouCreated:FrappeGroupOfThatUser /path/to/frappe/installation

now i face this problem “redis_socketio.1 stopped”

Try this…

sudo supervisorctl stop all
sleep 10
sudo killall -9 redis-server
sudo supervisorctl start all

xit, bye bye…
10:41:21 system | redis_cache.1 stopped (rc=-15)
no changed

In some of my case experiences, I had to restart supervisor several times.

@Kamrul.Hasan Try these commands:

bench set-maintenance-mode off
bench --site your-site set-maintenance-mode off

Keep bench start on one tab and try bench migrate && bench build on another tab

Error: No such command “build”.

Please run this command at your_project/frappe-bench path

~/frappe-bench$ bench build
Usage: bench [OPTIONS] COMMAND [ARGS]…
Try “bench --help” for help.

Error: No such command “build”.

post your whole command path

I just had a similar problem. Fix described here:

Dear Iulian Olaru

Thanks, It worked for me


Refer this video

worked for me too

This worked for me, However I had to manually go into “common_site_config.json” to set maintenance_mode to zero. The bench command did not change it for me, ( my instance was in production)

Screenshot%20from%202022-04-05%2017-30-58 "