Can't get app on my instance

Hello Team

I have just setup an instance and i am trying to install apps on it but i am faced with the error message below and its same for other applications too. please an urgent help is required

/frappe-bench$ bench get-app GitHub - ESS-LLP/process-manufacturing: PROCESS MANUFACTURING app oztro
INFO:bench.utils:git clone GitHub - ESS-LLP/process-manufacturing: PROCESS MANUFACTURING --depth 1 --origin upstream
Cloning into ‘oztro’…
remote: Counting objects: 58, done.
remote: Compressing objects: 100% (38/38), done.
remote: Total 58 (delta 16), reused 37 (delta 13), pack-reused 0
Unpacking objects: 100% (58/58), done.
Checking connectivity… done.
(‘installing’, u’process_manufacturing’) process_manufacturing
INFO:bench.utils:./env/bin/pip install -q -e ./apps/process_manufacturing --no-cache-dir
Command “python egg_info” failed with error code 1 in /home/ubuntu/frappe-bench/apps/process_manufacturing/
Traceback (most recent call last):
File “/usr/local/bin/bench”, line 11, in
load_entry_point(‘bench’, ‘console_scripts’, ‘bench’)()
File “/home/frappe/.bench/bench/”, line 40, in cli
File “/usr/local/lib/python2.7/dist-packages/click/”, line 722, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 697, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python2.7/dist-packages/click/”, line 895, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 535, in invoke
return callback(*args, **kwargs)
File “/home/frappe/.bench/bench/commands/”, line 40, in get_app
get_app(git_url, branch=branch)
File “/home/frappe/.bench/bench/”, line 135, in get_app
install_app(app=app_name, bench_path=bench_path, verbose=verbose)
File “/home/frappe/.bench/bench/”, line 179, in install_app
File “/home/frappe/.bench/bench/”, line 159, in exec_cmd
raise CommandFailedError(cmd)
bench.utils.CommandFailedError: ./env/bin/pip install -q -e ./apps/process_manufacturing --no-cache-dir

I think this issue is a bug on the recent update…

I have another instance i have setup in a while and i just tried installing on that instance and the apps ran successfully. I then uninstalled, did a bench update and tried installing a again then i get the errors again…

The erpnext team has to look into this urgently…


Any idea on fix for this


Some pip or python requirements missing?

You may use this instal process:

(AT)vinhnguyent090 is probably your best bet (he has solved many pip related problems) - but it is not polite to tag people directly.
Maybe look up his profile and see the solutions he has created for similar problems

My apologies…

1 Like

Hello thanks for your prompt response… I have run several clean installations and still arrived at same result. I don’t think the issue is with the installation.

Like I said I had an old instance I tried installing apps on, it installed perfectly after which I uninstalled then did bench update and tried same process and I ended with same error msg.

I can’t say for sure, but I think the old instance(s) were running pip v9.0.3, which gave very few errors. The more recent version have pip v10+ or v18, which seems to give the error 1 (permissions) problem, but Vincent is good/successful at solving those problems

@trentmu thank you for the hint…do you know Vincent’s handle so i can send him a message

replace (AT) with @ - remember to be nice and to not abuse his good nature :slight_smile:

What happens if you run

$ ./env/bin/pip install -e ./apps/process_manufacturing

Any more verbous error?

1 Like

Hi @EnSeal
You can try this

this is the error when i run above script

Obtaining file:///home/ubuntu/frappe-bench/apps/process_manufacturing
Complete output from command python egg_info:
Traceback (most recent call last):
File “”, line 1, in
File “/home/ubuntu/frappe-bench/apps/process_manufacturing/”, line 3, in
from pip.req import parse_requirements
ImportError: No module named req


Command “python egg_info” failed with error code 1 in /home/ubuntu/frappe-bench/apps/process_manufacturing/

This is a known compatibility issue with pip > v9.

In your, replace

from pip.req import parse_requirements


try: # for pip >= 10
   from pip._internal.req import parse_requirements
except ImportError: # for pip <= 9.0.3
  from pip.req import parse_requirements

then try again and it will work.


thanks all for the tip…Downgrading the pip version from 18.0 to 9.0.3 solved my issue