Developer mode, can not edit config file

Can not edit the setup jason file

ou do not have the permissions necessary to save the file. Please check that you typed the location correctly and try again.

tried install bench manager, but still not got that working



Hi and welcome to ERPNext Gray in Piscataway!

How are you editing what json config file? Please attach say a screenshot of the error and include your Role Permission page screen.

“tried install bench manager, but still not got that working”

What ‘official’ instructions or steps are you following - for context please include an error traceback that includes the command line so folks can help you.


Hi Many thanks for your responce,

I have now edited the file

“db_name”: “6d4b9452aef14153”,
“db_password”: “vqautaQ3Flw1w87s”,
"developer_mode: 1

and restarted the machine, but still no developer mode.

Not in Developer Mode! Set in site_config.json or make ‘Custom’ DocType.

for bench manager, i used the following GitHub - frappe/bench_manager: Frappe app for managing bench

gray@Erpnext-Pc:~/bench-manager.local/sites/bench-manager.local$ bench setup manager
Traceback (most recent call last):
File “/usr/local/bin/bench”, line 11, in
load_entry_point(‘bench’, ‘console_scripts’, ‘bench’)()
File “/home/frappe/.bench/bench/”, line 40, in cli
File “/usr/local/lib/python2.7/dist-packages/click/”, line 722, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 697, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python2.7/dist-packages/click/”, line 1066, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python2.7/dist-packages/click/”, line 895, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 535, in invoke
return callback(*args, **kwargs)
File “/home/frappe/.bench/bench/commands/”, line 182, in setup_manager
if ‘bench-manager.local’ in os.listdir(‘sites’):
OSError: [Errno 2] No such file or directory: ‘sites’

Many thanks


ok two issues -

  1. I am not at all familiar with the bench manager. That said it seems you are running ‘bench manager setup’ in the wrong directory - all bench commands must be run from for eg /home/frappe/frappe-bench. But you seem to be in say /home/frappe/frappe-bench//bench-manager.local/sites/bench-manager.local?

Provided you run ‘bench manager setup’ in /home/frappe/frappe-bench then the sites subdirectory is present as expected.

  1. developer_mode
    "restarted the machine, but still no developer mode.

Not in Developer Mode! Set in site_config.json or make ‘Custom’ DocType."

Rather than manually edit site_config.json I suggest this instead:

frappe@ubuntu:~/frappe-bench$ bench set-config developer_mode 1
frappe@ubuntu:~/frappe-bench$ find . -name site_config.json | xargs grep developer
./sites/site1.local/site_config.json: "developer_mode": 1, 

Your json file can be validated with this

Not sure if I am stating the obvious…but there is a missing closing quote here…

"developer_mode: 1

bench reload

“developer_mode” : 1

and it should do it


Hi Yes i think your right.

I have now undated to a fresh copy of Ubuntu 18.04 and started following these steps

Many thanks for all the help. I think it was just the " at the end, but i had already started again with Ubuntu 18.04 and the instruction to install on that version.

again ive hit a road block on command:bench new-site site1.local

Many thanks guys, i think it was the " at the end of developer, but i’d already started again with version 18.04 ubuntu 18.04 using the following instructions

but get stuck after issuing the following command: bench new-site site1.local

and get the following error File “/opt/bench/erpnext/env/local/lib/python2.7/site-packages/pymysql/”, line 109, in raise_mysql_exception
raise errorclass(errno, errval)
pymysql.err.InternalError: (1698, u"Access denied for user ‘root’@‘localhost’")

i have tried a few suggestions but still no luck

Thanks again, really finding my feet at the moment, with linux and Ubuntu

Try this :

Are you able to login to MySQL from the system check the database plugins for the login

Hi Guys, thanks for all the help. Got to the next stage, i have bench manager up and running. I have added another dev site but when i view site, http://testdev.local:8001/ i get server not found.

11:42:49 socketio.1 | listening on *: 9001
11:42:51 socketio.1 | { Error: connect ECONNREFUSED
11:42:51 socketio.1 | at Object._errnoException (util.js:992:11)
11:42:51 socketio.1 | at _exceptionWithHostPort (util.js:1014:20)
11:42:51 socketio.1 | at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1186:14)
11:42:51 socketio.1 | code: ‘ECONNREFUSED’,
11:42:51 socketio.1 | errno: ‘ECONNREFUSED’,
11:42:51 socketio.1 | syscall: ‘connect’,
11:42:51 socketio.1 | address: ‘’,
11:42:51 socketio.1 | port: 8001,
11:42:51 socketio.1 | response: undefined }
11:42:54 web.1 | * Running on (Press CTRL+C to quit)
11:42:54 web.1 | * Restarting with inotify reloader
11:42:54 watch.1 | yarn run v1.9.4

but list no other site

Im getting there its just a bumpy road, cheers again guys