[docker production installation] internal server error

the instance is suppose to run for 4hours (auto delete) from the counter it has been on for +40 min.

this is my instance :ip172-18-0-6-bvd1juhqckh000fklj4g-80.direct.labs.play-with-docker.com

on my side i can not get your instance opennin…how can i get your direct help on this for the deployment …:tired_face:

can you check logs for site-creator container?

contact me castlecraft.in

this si the current logs :
node1] (local) root@ ~
$ docker logs pwd_site-creator.1.gdqqk4duhzclo0wha5samhxh8
Attempt 1 to connect to mariadb:3306
Attempt 2 to connect to mariadb:3306
Attempt 1 to connect to redis-queue:6379
Attempt 1 to connect to redis-cache:6379
Attempt 1 to connect to redis-socketio:6379
Connections OK
Created user _285132e2c34995ba
Created database _285132e2c34995ba
Granted privileges to user _285132e2c34995ba and database _285132e2c34995ba
Starting database import…
Imported from database /home/frappe/frappe-bench/apps/frappe/frappe/database/mariadb/framework_mariadb.sql

Installing frappe…
Updating DocTypes for frappe : [========================================] 100%
Updating country info : [========================================] 100%

Installing erpnext…
Updating DocTypes for erpnext : [========================================] 100%
Updating customizations for Address
Updating customizations for Contact
*** Scheduler is disabled ***

which looks fine though.

Somehow i can see your instance

used this link

seems like the firewall that blocks me from accessing the real internet is playing its role now

Getting similar error on my end. Tried a lot workarounds and fixes.

Installation steps I followed:

  1. Pull the repo
  2. Modify the env-local to match the site names i wanted.
  3. Run docker compose

Things that i tried are

  1. Removing all volumes, network drives and bind volumes, so i can start from fresh
  2. Trying to manually allow a user (which i am guessing is one of the erpnext workers) GRANT ALL ON *.* TO '_c56bfbb8e06ec5a8'@'' IDENTIFIED BY 'admin'
  3. Adding MYSQL_ROOT_HOST=% to .env and even downgrading maraidb to 10.1 based on some post.

This issue is getting really frustrating to resolve. Any pointers to look anywhere else is really appreciated.

Some insight on the error
2021-11-01 6:50:47 162 [Warning] Access denied for user ‘_c56bfbb8e06ec5a8’@‘’ (using password: YES)
2021-11-01 6:51:47 163 [Warning] Access denied for user ‘_c56bfbb8e06ec5a8’@‘’ (using password: YES)
2021-11-01 6:52:36 165 [Warning] Access denied for user ‘_c56bfbb8e06ec5a8’@‘’ (using password: YES)

Using the env-local as the environment and the default docker-compose.yml file in the repo.

Running on Ubuntu 20.



This might the problem of your network the IP address changed, you can simply see the log of your logged differently .
In order to solve this , you can follow this instruction:

  1. Get into your docker MariaDB container

docker exec -it mariadb_database base

mysql -user -p then put your password the root’s password

grant all privileges on db_name.* TO 'db_name'@'%' identified by 'db_password';
FLUSH PRIVILEGES; <— don’t forget to run this command to make affect change .

  1. Restart your backend
    docker compose --project-name erpnext-one restart backend

this should be inside site_config.json

Note: to get the db_name and db_password you go to your site

Tree Em