Dropbox Backup question - UnicodeDecodeError arabic locale

I tried to reset dropbox settings but still the same error with private folder not being backed up,

Guys, any help regarding my backup problem?

I suggest you respond and contribute what you yourself have found, tried or done to resolve this?

Is there any error log?

@clarkej i did as u menstioned and reset dropbox settings, but still the same error i posted before, nothing has changed

You mean still this error!?

“OutgoingEmailError: Please setup default Email Account from Setup > Email > Email Account”

yes, and still does not backup private folder
i just did not setup email account for now,

Have you checked that the directory exists with the correct unix user, group, and file permissions?

For eg my case

frappe@erpnext:~/frappe-bench$ ls -al sites/erpnext.vm/private/files/*.png
-rw-r--r-- 1 frappe frappe   8204 Nov 22  2016 sites/erpnext.vm/private/files/GK.png

Sorry for Delay regarding updates,
First i setup email for notifications, now i get this error which seems to be the same error i get when i tried to install Bench manager

Backup Upload Failed
Oops, your automated backup to Dropbox failed.

Error message:

Traceback (most recent call last):
  File "/home/frappe/frappe-bench/apps/frappe/frappe/integrations/doctype/dropbox_settings/dropbox_settings.py", line 47, in take_backup_to_dropbox
    did_not_upload, error_log = backup_to_dropbox()
  File "/home/frappe/frappe-bench/apps/frappe/frappe/integrations/doctype/dropbox_settings/dropbox_settings.py", line 109, in backup_to_dropbox
    upload_from_folder(get_files_path(is_private=1), "/private/files", dropbox_client, did_not_upload, error_log)
  File "/home/frappe/frappe-bench/apps/frappe/frappe/integrations/doctype/dropbox_settings/dropbox_settings.py", line 128, in upload_from_folder
    for root, directory, files in os.walk(path):
  File "/home/frappe/frappe-bench/env/lib/python2.7/os.py", line 286, in walk
    if isdir(join(top, name)):
  File "/home/frappe/frappe-bench/env/lib/python2.7/posixpath.py", line 73, in join
    path += '/' + b
UnicodeDecodeError: 'ascii' codec can't decode byte 0xd8 in position 1: ordinal not in range(128)

I read another topic regarding this error, but i cant seem to understand how to find that ascii codec that is giving me this error

First i setup email for notifications, now i get this error which seems to be the same error i get when i tried to install Bench manager
Good so you setup you email as prompted, that hid this traceback of the problem you seek.

The traceback says a filename in your /private/files has a character that causes the upload to Dropbox to fail. So inspect the filenames there, to identify the problem filename. You may need rename it

Which version of frappe you are using. We have fixed this issue. If you are on latest version, please let us know.

i am on 10.1.29 frappe and erpnext on 10.1.30

i have file names that has arabic letters in it, but it never was a problem before in earlier versions, it used to backup filenames with arabic letters normally to dropbox

We will check into this and update you soon,

any new info regarding my problem?

Hello guys
Just checking for any new news regarding this problem of mine,
Thank you

@clarkej @saurabh6790

i tried and reset the server and made a fresh install ( after a lot of work due to easy install didnot work for me and used the manual part that took me a while to get everything in correct place ) and tried again with dropbox backup but still does not upload private files or files to dropbox, only database
i tried manual backup and it worked, it sent me an email with a link to database, private files folder and files folder and i downloaded them manually

“Just checking for any new news regarding this problem of mine,”

Please report it here Issues · frappe/erpnext · GitHub and include there a reference link to this thread, thanks.

@clarkej @saurabh6790
My problem is fixed, and this is how i fixed it,
I checked perl locals settings and found out that there is no arabic local ar-utf-8 setting in iy, i added it to the en-utf-8 and tried backup again, and it worked for all files
Thanks guys, but did not think that the solution would be that simple :slight_smile:
Hope it would help other guys if they face same error but with other languages
i used this lilnk to change perl locals so thought i would help other people on how to do it

Good to hear you fixed your problem, thanks for your update.