Dropbox Integration issue (redirect Error) - using Docker image

I am using docker image and I am having issues with dropbox integration.
I found a solution on forum but I am unsure where to run the bench command.


bench set-url-root example.com https://example.com

ERPNext: v12.10.1 (version-12)
Frappe Framework: v12.8.4 (version-12)

Error is
Invalid redirect_uri. When response_type=code, only localhost URIs can start with “http://”; all others must start with “https://”

1 Like

add key "host_name" to site_config.json

refer frappe_docker/site-operations.md at main · frappe/frappe_docker · GitHub

Thanks or your response
I have added “hostname”:“foo.com” to sites/foo.com/site_config.json and restarted the dockers but still dropbox gives the same error.
I have used redirect uri as below


but it shows the url without http’s and gives error

I have tried to typein the missing S in the url and it moves ahead for authtication finally I get this error

requests.exceptions.HTTPError: 400 Client Error: Bad Request for url: https://api.dropboxapi.com/oauth2/token

Check the field.


Reference in code: bench/bench/config/site_config.py at develop · frappe/bench · GitHub

Now a new Error

Error message: No Access Token exists!
I edited site_config.json it using to add the dropbox _access_key and dropbox_secret_key
docker run
-v foo_sites-vol:/sites
alpine vi /sites/foo.com/site_config.json

By Config File is as below

“db_name”: “Something”,
“db_password”: “Something”,
“db_type”: “mariadb”,
“encryption_key”: “-Lies In Between-j-EjEeI=A8”,
“dropbox_access_key”:“app_KeyFrom DropBox”,
“dropbox_secret_key”:“Top Secret From DropBox”


After editing I ran the following command

  • docker stop $(docker ps -a -q)
  • docker-compose --project-name foo up -d

I’m not using dropbox. I won’t be able to debug that.

I use S3 compatible storage for backups, that is part of docker tests that run everyday. It starts a MinIO container to emulate S3 and run backup restore from there.

“host_name” should include https://

I am also facing the same problem. Anybody able to solve this in docker deployments?

So we checked the frappe code

what we have to do in from common_site_config.json remove webserver_port and restart the server

And add /api/method/frappe.integrations.oauth2_logins.login_via_google in oauth google

Nothing in common_site_config.json, add key host_name in site_config.json.

add the following nearer the start of your init.sh
bench --site {{site-name}} set-config restart_supervisor_on_update 1
bench --site {{site-name}} set-config restart_systemd_on_update 1