Easy setup error

TASK [bench : python2 bench init for production] *******************************
fatal: [localhost]: FAILED! => {“changed”: true, “cmd”: [“bench”, “init”, “/home/frappe/frappe-bench”, “–frappe-path”, “GitHub - frappe/frappe: Low code web framework for real world applications, in Python and Javascript”, “–frappe-branch”, “master”], “delta”: “0:00:00.562863”, “end”: “2019-03-26 18:23:36.786576”, “msg”: “non-zero return code”, “rc”: 1, “start”: “2019-03-26 18:23:36.223713”, “stderr”: “Traceback (most recent call last):\n File "/bin/bench", line 6, in \n from pkg_resources import load_entry_point\n File "/usr/lib/python2.7/site-packages/pkg_resources/init.py", line 3191, in \n @_call_aside\n File "/usr/lib/python2.7/site-packages/pkg_resources/init.py", line 3175, in _call_aside\n f(*args, **kwargs)\n File "/usr/lib/python2.7/site-packages/pkg_resources/init.py", line 3204, in _initialize_master_working_set\n working_set = WorkingSet._build_master()\n File "/usr/lib/python2.7/site-packages/pkg_resources/init.py", line 583, in _build_master\n ws.require(requires)\n File "/usr/lib/python2.7/site-packages/pkg_resources/init.py", line 900, in require\n needed = self.resolve(parse_requirements(requirements))\n File "/usr/lib/python2.7/site-packages/pkg_resources/init.py", line 786, in resolve\n raise DistributionNotFound(req, requirers)\npkg_resources.DistributionNotFound: The ‘GitPython==2.1.11’ distribution was not found and is required by bench”, “stderr_lines”: [“Traceback (most recent call last):”, " File "/bin/bench", line 6, in “, " from pkg_resources import load_entry_point”, " File "/usr/lib/python2.7/site-packages/pkg_resources/init.py", line 3191, in “, " @_call_aside”, " File "/usr/lib/python2.7/site-packages/pkg_resources/init.py", line 3175, in _call_aside", " f(*args, **kwargs)“, " File "/usr/lib/python2.7/site-packages/pkg_resources/init.py", line 3204, in _initialize_master_working_set”, " working_set = WorkingSet._build_master()“, " File "/usr/lib/python2.7/site-packages/pkg_resources/init.py", line 583, in _build_master”, " ws.require(requires)“, " File "/usr/lib/python2.7/site-packages/pkg_resources/init.py", line 900, in require”, " needed = self.resolve(parse_requirements(requirements))“, " File "/usr/lib/python2.7/site-packages/pkg_resources/init.py", line 786, in resolve”, " raise DistributionNotFound(req, requirers)", “pkg_resources.DistributionNotFound: The ‘GitPython==2.1.11’ distribution was not found and is required by bench”], “stdout”: “”, “stdout_lines”: []}
to retry, use: --limit @/tmp/.bench/playbooks/site.retry

Try this post…

thanks, i have tried. but still the same error :frowning:

What OS are you trying to install on? Completely fresh install on completely fresh system?

Provide that info anyway, but based on:

pkg_resources.DistributionNotFound: The ‘GitPython==2.1.11’ distribution was not found and is required by bench

I’d say that your issue is that you don’t have the prereq’s installed. Assuming some form of debian/ubuntu as a clean install, make sure to run:

At a minimum:

apt-get install build-essential python-minimal python-setuptools -y

(sudo if not root)

For best results, add:

curl -sL https://deb.nodesource.com/setup_10.x | sudo -E bash -
apt-get install -y nodejs

After those are done, do your wget for the easy install and run it.

thank you very much . i think you are right . trying now

i have successfully install erpnext with production.

but how to start it? my OS is centos 7.

i visit the server IP. but show blank.

For production, the system should start automatically (No need to run bench start). Once you have it running, point your browser to http://IP.address.or.FQDN:8000 - unless you adjusted the port in your setup. eg. If your machine is and the port you set was 8100, then it would be

after i restart the OS, it shows below:

We will be back soon.
Don’t panic. It’s not you, it’s us.
Most likely, our engineers are updating the code, and it should take a minute for the new code to load into memory.

Try refreshing after a minute or two.

Assuming it’s been like that for a while and without any other details, make sure:

  1. The system it’s running on has access to the internet (see)

  2. There are no firewall issues- typically, ERPNext uses 80, 443, and… 6787(?) when hosted as a domain with nginx up and running, or 8000 and 9000 when running locally. These are the defaults; your configuration may vary. Easiest way to see if the issue is something firewall-related is to just briefly disable any firewall you know of between you and the host system and see if it works. If so, reenable the firewalls and look into what ports are configured vs what is needed.

  3. From your bench directory (default is ‘frappe-bench’) on the host system, run:

    bench update
    bench restart
    sudo service nginx restart

If the site is set up, you still error with the firewalls down, and the update/restart regime doesn’t work, take a look at the error logs and see if anything pops out. If there is a repeating, quasi-repeating, or timestamp-corresponds-to-your-access attempts message, post a screenshot.

1 Like

my worked on 80 port so check the port in nginx config file