ERP Next - Journal Entry Import


I am trying to import a number of journal entry items.

The import file appears to be correct and maps to the correct columns but when I try and submit, the system throws: “Incorrect number of General Ledger Entries found. You might have selected a wrong Account in the transaction”.

What else could be wrong?
I have attached a hyperlink of the upload file for reference.
( File Format


Hi. I did not think it had anything to do with inventory as we do not use the module. I nevertheless tried it and get the same result.


There is a problem in your data import file format.

You are trying to upload 82 entries (each entry has two rows of records) so you will add journal entry parent fields at the first row of each entry. So you have 82 headers (not one header like you did in Entry Type, Series and Company nor 164 headers like you did in Posting Date).

So you will add the headers at the first row and leave the second row blank.

Hi I’m also having the same issue but I would love if @BarryHavenga can resend the link to the google drive for the data imported(I mean the raw data import) so that I can understand what @ahmed.sharaf said concerning the entries and headers he talked about.

I have attached a hyperlink of the upload file for reference.(Journal_Entry - Google Sheets)



Unfortunately I can’t assist. We have a large number of credit loan accounts & interest arising which ERP Next at this stage doesn’t handle, so we deferred implementation until it does.

I therefore deleted the data so I am afraid I no longer have the import entry. I do remember that I was eventually succesful in doing the import.


Okay thanks, but if you do not mind, can briefly explain how you go about the upload successfully. I am willing to learn.