ERPNext on a Raspberry Pi 3 with Debian 9

merged this change.

@revant_one Hey erpnext-worker image also needs some changes .
Because building that image is also causing permission denied error after running container
It surely has to do something with USER command in Dockerfile
I changed it to root and than container was agreed to run but all apps was installed in local/bin folder so couldn’t setup but it was running without any error
Here is error from that container

And why everything is setup with USER root ?
Is it causing frappe user to access those files and folders ?

~/apps/frappe_docker $ docker container logs erpnext-hanger-configurator-1 standard_init_linux.go:219: exec user process caused: permission denied

I tried to exec in that container and changing permission to frappe but nothing works
I don’t know how server can build image without these errors
And also I can run prebuilt images for arm beta V1 from server without any error but building it doesn’t

to make sure application code is not editable by non root user.

Send a PR and description of your proposed changes we can discuss there.

Hey so now I am successfully abble to build image for arm64 and only erpnext stack build is taking only less then 6 minutes
And now with trial and error I took conclusion that there were no any error in Dockerfile
It was git who is not preserving files permission when cloning repository without root
So i had to clone repository with sudo and then build it successfully.
So you can revert my pr if you find not necessary
But I have suggestion that if we set permission in Dockerfile than it will be also eliminate this errors
I open new question issue on github

1 Like

Can we add the instructions to install it on arm64 arch on docker repo of frappe? On Pi or any other arm based system?

If you’ve steps that others can replicate add them under docs and list them on README of frappe_docker repo and send a pull request.

I don’t have right now. But as I saw in the thread that they were successfully able to install it on the arm64 based arch, I asked if we can add it on the repo. However, I’ve not tried it yet but I’ll be trying it soon. I’ll update If I’m able to successfully run it on my Pi 4b 8GB.

1 Like

FYI, it only takes about 11 minutes now to build the images on a pi. Might not be a bad time to put them under the supported archs.

The only problem I have is that either docker or the compose are too different from what i have before. Even building the images, I can’t use compose up as it doesn’t see the images I baked for some reason.

EDIT: fixed that part but got another error with a 404. It’s quite frustrating how often the build instructions change. In the last year, there’s been four completely different ways of installing EPR Next and none of the ones I used before still work.

1 Like