ERPNext V12 easy install on fresh Ubuntu 18.04 error code 1

Hello i want to install install erpnext V12 on Ubuntu 18.04

After when I try to install

It shows this error

izatafghan@vmi552623:~$ sudo python3 --production
[sudo] password for izatafghan:
Logs are saved under /tmp/logs/easy-install__2021-03-27__17-34.log
Checking System Compatibility…
ubuntu 18 is compatible!
Extracting templates from packages: 100%
curl already installed!
wget already installed!
git already installed!
Installing pip3…
pip3 installed!
Command “python egg_info” failed with error code 1 in /tmp/pip-build-d0dp52ns/cryptography/
Traceback (most recent call last):
File “”, line 436, in
File “”, line 143, in install_prerequisites
‘python3’: “sudo -H python3 -m pip install --upgrade setuptools cryptography ansible==2.8.5 pip”
File “”, line 118, in run_os_command
returncode = subprocess.check_call(command, shell=True, stdout=log_stream, stderr=sys.stderr)
File “/usr/lib/python3.6/”, line 311, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘sudo -H python3 -m pip install --upgrade setuptools cryptography ansible==2.8.5 pip’ returned non-zero exit status 1.

Please help.

Thanks in advance

May we know which easy install method is being followed?

I tried this method

Also this one

Both show the same error

My VPS server has 8gb ram 4core and 200SSD capacity. With all opened ports related to erpnext

If you can dump the output of this file, it would give a better idea what the issue is.

This is log file

GNU nano 2.9.3 easy-install__2021-03-28__18-54.log
Hit:1 bionic InRelease Hit:2 bionic-updates InRelease
Hit:3 bionic-backports InRelease
Hit:4 bionic-security InRelease
Reading package lists… Reading package lists…
Building dependency tree…
Reading state information… build-essential is already the newest version (12.4ubuntu1).
libffi-dev is already the newest version (3.2.1-8). python3-setuptools is already the newest version (39.0.1-2).
git is already the newest version (1:2.17.1-1ubuntu0.8). python3-dev is already the newest version (3.6.7-1~18.04).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Collecting setuptools Using cached$Collecting cryptography
Using cached$ Complete output from command python egg_info:

        =============================DEBUG ASSISTANCE==========================
        If you are seeing an error here please try the following to
        successfully install cryptography:
        Upgrade to the latest pip and try again. This will fix errors for most
        users. See:
        =============================DEBUG ASSISTANCE==========================

Traceback (most recent call last):
  File "<string>", line 1, in <module>                                                      File "/tmp/pip-build-o3jkhdhv/cryptography/", line 14, in <module>
    from setuptools_rust import RustExtension
ModuleNotFoundError: No module named 'setuptools_rust'                                

Install script run at 18:54 on 2021-03-28

           [ File 'easy-install__2021-03-28__18-54.log' is unwritable ]