Error installing last ERPNext develop version from scratch

Hi @ManishKumar,

Have you tried following the steps @JoEz posted here: Error installing last ERPNext develop version from scratch - #11 by JoEz ?

Clear cache usually works. If not, you can try doing the steps for Manual Install. But first, try out JoEz’s steps. :slight_smile:

it seems doesn’t work anymore …

I think it’s a case to case basis. :slight_frown:
Clear cache works half of the time but for other cases, you’ll have to install something or update something.

@littlehera @ManishKumar i finally has been able to complete setup-wizard …keep running bench clear-cache every time it get stuck, until it will succeed

1 Like

Running into the same issue here.

When using bench clear-cache I got to the point where it created the Accounts but then it was stuck again. Guess that’s about the end. But I’m unable to complete the setup wizard.

Maybe build in a way to skip it? At least for development.

// EDIT:

Same for just the frappe setup wizard. I ran bench clear-cache and changed the name of the new user, twice, because then it complained that the same user already exists. After that I could complete the setup.

I get the same issue installing development mode on fresh Ubuntu 16 on AWS EC2 micro instance. If someone from ERPNext could take a look at doing the same could easily fix the issue.

I did bench clear-cache several times with no luck.

keep trying …do bench clear-cache and click on setup wizard to continue …

Killed almost 10 hours trying different options and no success with dev mode. Finally solved by installing ERPNext in production mode and changing to developer mode. Steps below.

  1. Install ERPNext in production mode
  2. Follow the setup wizard and setup first site.
  3. Change from production mode to developer mode following instructions on Stopping Production and starting Development · frappe/bench Wiki · GitHub