Error Message "Tools not found" when editing Desktop Icons

Hello everyone,

I just tried to add a desktop icon (menu option “Set Desktop Icons” under my user name) and when I tried to save the result, I got the error message “Tools not found” and the change is not saved. I am using:
erpnext 10.0.17
frappe 10.0.18

Thanks in advance for your help.

Edit – I just noticed that the “About” menu gives me a different version for ERPNext and Frappe Framework:

Looks like you ended up installing the develop branch. You need to install the master branch if you’re using ERPNext for production. Develop branch is unstable.

It would be best to switch to master branch first

1 Like

You can solve this problem with following commands it works for me.

Note : Execute commands from frappe-bench folder.

Step 1 : Remove your actual site by using bench drop-site site1.local
Step 2 : bench switch-to-master
Step 3 : bench new-site site1.local --install-app erpnext

1 Like

Thank you all for your answers. When I ran bench switch-to-master, I got:

frappe@pi1:~/frappe-bench $ bench switch-to-master
remote: Counting objects: 41, done.
remote: Compressing objects: 100% (17/17), done.
remote: Total 41 (delta 25), reused 20 (delta 20), pack-reused 4
Unpacking objects: 100% (41/41), done.
   8ea802709..267d16575  develop          -> upstream/develop
   565ca0079..04cb1d083  hotfix           -> upstream/hotfix
 * [new branch]          revert-4133-grid -> upstream/revert-4133-grid
Switching for frappe
INFO:bench.utils:git config --unset-all remote.upstream.fetch
INFO:bench.utils:git config --add remote.upstream.fetch '+refs/heads/*:refs/remotes/upstream/*'
INFO:bench.utils:git fetch upstream
INFO:bench.utils:git checkout master
Already on 'master'
Your branch is up-to-date with 'upstream/master'.
INFO:bench.utils:git merge upstream/master
Already up-to-date.
remote: Counting objects: 16, done.
remote: Compressing objects: 100% (11/11), done.
remote: Total 16 (delta 13), reused 8 (delta 5), pack-reused 0
Unpacking objects: 100% (16/16), done.
   9f29f6070..2afa8277a  develop    -> upstream/develop
 * [new tag]             v10.0.18   -> v10.0.18
Branch master does not exist in Upstream for erpnext
Successfully switched branches for:
Switched to master

As you can read, “Branch master does not exist in Upstream for erpnext” and therefore I am still with version v9.x.x-develop (9f29f60) (develop) in the “about” menu.

Try this
Step 1 : goto frappe-bench/apps/ and Remove erpnext ---->$ rm -r erpnext
Step 2 :Goto frappe-bench/------> $ bench get-app erpnext GitHub - frappe/erpnext: Free and Open Source Enterprise Resource Planning (ERP) --branch master
Step 3 : bench update.
you’ll have frappe as well as erpnext in master branchmaster-bench

1 Like

Thank you very much @mayuri for your clear instructions. I now have both ERPNext and Frappe as “masters”. The thread can be closed.