Error: Value missing for Assessment Plan: Course

Please help me rectify this error


Im also getting the same error.

Im trying to create an Assessment Plan, im not succesful.

ERPNext: v11.0.3-beta.10 () (staging)

Frappe Framework: v11.0.3-beta.9 () (staging)

Any Help will be Appreciated. Thanks in advance.

Perhaps this link will help

Thanks for Quick Response. Ive tryed the solution in the link, unfortunately still getting same error.

But all is ok in another instance i have running (erpnext develop branch that has not been updated in past 1 month).


Can you share an errorlog or traceback screen?

Thanks again.

Ok, Nothing is showing in error log also no traceback error. Looks more like a validation error. Just error message and Assessment Plan doesnt save.


Could you comment the screenshot here? Also please let us know the branch which you are using?

ERPNext: v11.0.3-beta.10 () (staging)

Frappe Framework: v11.0.3-beta.9 () (staging)


Anybody who could rectify the above error please help

I am getting the same error with v11.1.3. Configuring “Default Grading Scale” did not resolve this.

ERPNext: v11.1.3 (master)
Frappe Framework: v11.1.3 (master)

Tested with following branch and it is working fine:

ERPNext: v11.x.x-develop (2694318) (develop)
Frappe Framework: v11.x.x-develop (e180b41) (develop)

Anyone there to guide me?


i also have same error did u find any solutions to it?

Getting same error in

ERPNext: v11.1.36(master)
Frappe: v11.1.33(master)

Hi, if I customize the form and set null for “Fetch From” [student_group.course, course.default_grading_scale] then these issues are disappearing. However, I am not sure about the impact of such customization.

Please help.



I am having same issue with latest version of erpnext:

ERPNext: v11.1.58 (version-11) 
Frappe Framework: v11.1.53 (version-11)

Setting Course Default Grading Scale also gives same error.
Also tried
bench update
bench migrate
bench clear-cache

Any help is appreciated.


hi @Sudarshan_Pathak, may yo tell me , if you find de solution?
the group_student is based by batch, but de assesstent plan tray to get by course:

eval:doc.group_based_on == ‘Course’

Does anyone know how to fix this error?

Have you got a solution to the issue Error: Value missing for Assessment Plan: Grading Scale

Set grading scale in course and that will fix the problem.

Thank you very much. I have got it right.

@ssemotom Are you able to generate report card with all the courses in the same table?