Error while installing erpnext bench init frappe-bench && cd frappe-bench

I am getting an error while trying to install erpnext in bench 4.1.0.

when giving bench init frappe-bench && cd frappe-bench

/home/erpnext/frappe-bench/env/bin/python: cannot open shared object file: No such file or directory Traceback (most recent call last): File "/usr/bin/bench", line 9, in <module> load_entry_point('bench==4.1.0', 'console_scripts', 'bench')() File "/home/erpnext/bench-repo/bench/", line 40, in cli bench_command() File "/usr/lib/python2.7/site-packages/click/", line 716, in __call__ return self.main(*args, **kwargs) File "/usr/lib/python2.7/site-packages/click/", line 696, in main rv = self.invoke(ctx) File "/usr/lib/python2.7/site-packages/click/", line 1060, in invoke return _process_result(sub_ctx.command.invoke(sub_ctx)) File "/usr/lib/python2.7/site-packages/click/", line 889, in invoke return ctx.invoke(self.callback, **ctx.params) File "/usr/lib/python2.7/site-packages/click/", line 534, in invoke return callback(*args, **kwargs) File "/home/erpnext/bench-repo/bench/commands/", line 19, in init verbose=verbose, clone_from=clone_from) File "/home/erpnext/bench-repo/bench/", line 67, in init build_assets(bench_path=path) File "/home/erpnext/bench-repo/bench/", line 171, in build_assets run_frappe_cmd('build', bench_path=bench_path) File "/home/erpnext/bench-repo/bench/", line 501, in run_frappe_cmd raise CommandFailedError(args) bench.utils.CommandFailedError: ('build',)

I tried reinstalling MySQL-python dependency and also given pip install python-mysql but the error persists.

pls help me

pip uninstall mysql-python
apt-get install libmysqlclient-dev
pip install mysql-python

Thanks @netchampfaris , But i alreeady tried it, I am using CENTOS 7 server
libmysqlclient-dev is not present in it.

pip uninstall mysql-python pip install mysql-python

I already tried this but not working.

I searched my server for

I found that my server has only.

What could be wrong.

Should i upgrade mariadb 10.0 to mariadb 10.1 or 10.2 which may fix the problem by giving
is this a problem. ERPNext says it needs only mariadb 10.0 only.

Try upgrading mariadb to 10.1

@netchampfaris nops,
the problem persists upgrading mariadb didnt worked too.