Errors After Upate v6.27.12

What is the migration error above that trace? When upgrading and an error occurs in migrate you get back two traces.


i get the same errors as @applepipe has described or shown on here, when trying to follow your steps…

also, if i go to the end and do all your steps, and try to access the system via the web interface, i get the below errors

Traceback (most recent call last): File "/home/frappe/frappe-bench/apps/frappe/frappe/website/", line 25, in render data = render_page_by_language(path) File "/home/frappe/frappe-bench/apps/frappe/frappe/website/", line 91, in render_page_by_language return render_page(path) File "/home/frappe/frappe-bench/apps/frappe/frappe/website/", line 107, in render_page return build(path) File "/home/frappe/frappe-bench/apps/frappe/frappe/website/", line 114, in build return build_page(path) File "/home/frappe/frappe-bench/apps/frappe/frappe/website/", line 127, in build_page context = get_context(path) File "/home/frappe/frappe-bench/apps/frappe/frappe/website/", line 16, in get_context context = build_context(context) File "/home/frappe/frappe-bench/apps/frappe/frappe/website/", line 64, in build_context ret = module.get_context(context) File "/home/frappe/frappe-bench/apps/frappe/frappe/templates/pages/", line 21, in get_context boot = frappe.sessions.get() File "/home/frappe/frappe-bench/apps/frappe/frappe/", line 107, in get bootinfo["notification_info"] = get_notification_info_for_boot() File "/home/frappe/frappe-bench/apps/frappe/frappe/desk/", line 133, in get_notification_info_for_boot out = get_notifications() File "/home/frappe/frappe-bench/apps/frappe/frappe/desk/", line 26, in get_notifications "open_count_doctype": get_notifications_for_doctypes(config, notification_count), File "/home/frappe/frappe-bench/apps/frappe/frappe/desk/", line 92, in get_notifications_for_doctypes filters=condition, limit_page_length = 21, as_list=True)) File "/home/frappe/frappe-bench/apps/frappe/frappe/", line 1016, in get_list return frappe.model.db_query.DatabaseQuery(doctype).execute(None, *args, **kwargs) File "/home/frappe/frappe-bench/apps/frappe/frappe/model/", line 72, in execute result = self.build_and_run() File "/home/frappe/frappe-bench/apps/frappe/frappe/model/", line 92, in build_and_run return frappe.db.sql(query, as_dict=not self.as_list, debug=self.debug) File "/home/frappe/frappe-bench/apps/frappe/frappe/", line 147, in sql self._cursor.execute(query) File "/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/MySQLdb/", line 205, in execute self.errorhandler(self, exc, value) File "/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/MySQLdb/", line 36, in defaulterrorhandler raise errorclass, errorvalue OperationalError: (1054, "Unknown column 'tabSupplier.status' in 'where clause'")

That screenshot didnt have the full traceback. Can you share the full output of the bench update step.

I am facing the issue of not being able to see the Developer and Setup module (but able to access it from the awesome bar) after changing the frappe branch from develop to master. Now, looks like you have recommended us to move to develop branch for both erpnext and frappe. Is it soon going to be merged? Else I can see that we will face more of such issues.

1 Like

Hi @anand

Sorry to pester you with this , but we need a solution for this. As it stands the system is unusable and we are stuck with these errors and no working solution so far…

I would appreciate it if you could please find a fix for this or suggest an alternative solution…

Many Thanks

Here is the full output:

So apparently it was the locale setting, but I did what was discussed in the topic Bench update throwing an error - #5 by sunilsrikumar

The result is still an error, but a different one now:

I updated again the VM that was still in master branch, same locale error, fixed this issue and the update ran perfectly. Opened the browser with hope that everything was fixed, “ImportError: No module named buying”.

For locale error, see: Locale error during install/update/ssh - #3

@ermalc can you send the output of your update command?


on top of all of the above issues, my one now comes up with INTERNAL SERVER ERROR , so can’t even access the web interface at all…

see attached print screen after update

Please send me full trace and not just print screen of part of the trace.


i would happily send you the whole log if i knew how to copy this from the virtual box window or how to export it…

if you know a way , please share

I already read this topic, I even posted the link… Now I’m having another issue, also in the same post.

Are you on windows? If so, you can use putty to access the virtual machine via ssh and copy the outputs normally.


`Last login: Sun May 1 12:50:22 2016
frappe@erpnext:~$ cd frappe-bench
frappe@erpnext:~/frappe-bench$ bench update
INFO:bench.utils:updating bench
Already up-to-date.
Requirement already satisfied (use --upgrade to upgrade): Pillow in ./env/lib/python2.7/site-packages frappe
From GitHub - frappe/frappe: Low code web framework for real world applications, in Python and Javascript

*** Please tell me who you are.


git config --global “
git config --global “Your Name”

to set your account’s default identity.
Omit --global to set the identity only in this repository.

fatal: unable to auto-detect email address (got ‘frappe@erpnext.(none)’)
Traceback (most recent call last):
File “/usr/local/bin/bench”, line 9, in
load_entry_point(‘bench==0.92’, ‘console_scripts’, ‘bench’)()
File “/home/frappe/bench-repo/bench/”, line 40, in cli
File “/usr/local/lib/python2.7/dist-packages/click/”, line 716, in call
return self.main(*args, **kwargs)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 696, in main
rv = self.invoke(ctx)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 1060, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File “/usr/local/lib/python2.7/dist-packages/click/”, line 889, in invoke
return ctx.invoke(self.callback, **ctx.params)
File “/usr/local/lib/python2.7/dist-packages/click/”, line 534, in invoke
return callback(*args, **kwargs)
File “/home/frappe/bench-repo/bench/commands/”, line 61, in update
_update(pull, patch, build, bench, auto, restart_supervisor, requirements, no_backup, upgrade, force=force)
File “/home/frappe/bench-repo/bench/commands/”, line 77, in _update
File “/home/frappe/bench-repo/bench/”, line 93, in pull_all_apps
exec_cmd(“git pull {rebase} upstream {branch}”.format(rebase=rebase, branch=get_current_branch(app, bench=bench)), cwd=app_dir)
File “/home/frappe/bench-repo/bench/”, line 99, in exec_cmd
raise CommandFailedError(cmd)
bench.utils.CommandFailedError: git pull upstream master


Do you have a custom app?

I think solution is here Error while making bench migrate

For me it worked

  1. bench switch-to-master
  2. bench update --patch - it will show some error
  3. bench mysql
  4. ALTER TABLE tabDocType DROP COLUMN track_seen;
  5. ALTER TABLE tabDocType DROP COLUMN quick_entry;
  6. Exit the SQL terminal, and run bench update

@anand , no, absolutely nothing, just the virtual image disk without any custom work or any additional apps.

@Nitto , thank you for your suggestion, but after trying your suggestion, i still get the exact same issues and error codes as above, still not working…

Hi All

After doing some research on here, there are many users who are experiencing the same issues.

Thanks to @vjFaLk and @anand for supplying parts of the same solution.

All of the steps i took to resolve and finally update to the latest version…

cd frappe-bench/apps/erpnext_demo directory
git reset --hard upstream/master

cd /home/frappe/bench-repo
git checkout develop
git fetch origin develop
git reset --hard origin/develop
cd /home/frappe/frappe-bench
bench switch-to-develop
bench update
bench setup redis
bench setup supervisor
sudo supervisorctl reread
sudo supervisorctl update

The above worked for me, i hope it helps someone on here…