Failed to setup company


bench@vps552324:~/erpnext$ bench --version

Already updated bench and reinstalled. Even tried this with no success:

In [4]: setup_complete(args)
Out[4]: {u'fail': u'Failed to setup company', u'status': u'fail'}

Tried reinstall site:

bench --site site1.local reinstall

Have no idea what to do. M.b. something goes wrong with installation?
I did a manual install on a clean Ubuntu 18 step by step with no errors (since easy install was a little buggy for me on Ubuntu 14/16/Debian 9)

Okay, if site deleted

bench drop-site site1.local

and installed again

bench new-site site1.local

setup goes to finish (without asking domain, company name, etc) but all stuff without apps and help docs. When do

bench install-app erpnext

it stuck with “Duplicate name Domain…” and so on as above.
Whats the heck is going on? :confused:

So I assume that at this point, ERPNext wasn’t installed on the site?

I am facing the same issue in a fresh setup!

I also tried re-installing (bench reinstall). Even reinstalling from scratch did not work.

Bump. Same issue with the latest fresh installation of Frappe and ERPNext using Bench. Tried using the VM too, the same issue is occurring there as well.

I just took a fresh pull - bench update and it worked after that.

Nope, I dropped installation because I didn’t know what else to do. So I deployed Ubuntu 16 (since v18 unsupported by easy script) on my VPS and run easy install. But this time with fix by @codingCoffee and installed with success.

That’s strange because I updated bench too but without any result.

I have the same problem on a completely fresh installation. Don’t know what to do.

bench --version

Python 3.6.5 :: Anaconda, Inc.
Ubuntu 18.04

Can anyone help?

I deleted everything again and followed the hitchhikers tutorial again. But this time I did not skip this step:
bench config dns_multitenant on
and now the setup works!