File Upload Disconnected. Please try again

This can also be recreated on the demo site in Upload Attendance section, by uploading attendance template there.

I have the same problem.Even in switching from develop to master.
And report it as an issue.

Attendance issue will be fixed. @saurabh6790

i m still having the file upload discconected problem on this versions :

my erpext version is v9.2.4(master)
my frappe version is v9.2.6(master)

with the administrator account i am able to upload files even with the error message but with the other accounts is impossible

1 Like

rmehta ERPNext FoundationSep 27
Pushed a fix
Please wait for it to be merged.

it already merged but the problem still exists, im suffering this problem i had this versions:

erpnext 9.2.7
frappe 9.2.9

Thank you everyone…

In which place does this sill come? Can you share your JS console too?

I can confirm this problem is still the happening in current stable and development versions. In my case, I was accessing via a local IP (not and observed similar problems as mentioned by @vkcr. I found the solution required 2 steps:

  1. Access the site only by hostname which matches your site name <yoursite>.
  2. Ensure both the erp user and nginx user (if active) have write access to sites/<yoursite>/private/files/
1 Like

Same here still happens after updating to latest version, any chance related with socketio fallback not running?

erpnext 9.2.13
frappe 9.2.14


edit: solved using chmod on uploads folder refer here GitHub - bitnami/vms: Bitnami Application Catalog VMs

Same issue here, and chmod doesn’t solve this issue as it’s related to socketio.

erpnext 9.2.13
frappe 9.2.14

Yes, i have seen your video there is noting wrong or error in the Javascript.

Hi all,

any news on this? The error still appears after a successful file upload in Frappe Framework: v9.2.20 (master).

(Maybe) interesting observation: on the same system, we observe the error when using the ERPNext in Firefox (v57) private mode but not in normal mode. When the error occurred, a refresh (F5) of the page with a subsequent file upload also did not reproduce the issue. All cases uploaded the file.

1 Like

Hi everyone, I’m facing this exact problem, any updates on the problem?

1 Like

I bumped into this problem after updating one of my online servers. This problem DOES NOT replicate on other servers which I recently updated, so this is clearly isolated to a single server or a setting of some sort.
I am on master branch and:

Upon instalaltion of ERPNext v10, and after rebooting the server and starting the bench, I go to the ERPNext site and try to upload an image for an item. I get the same error.

File Upload Disconnected. Please try again.

Doing a trace of the JavasCript console, nothing jumps out. I would like to try @vkcr’s workaround but am still working on how best to do it.

Clearly, from what I understand it has to do with any suggestions on how best to investigate further?

UPDATE: The best workaround I have found is to backup the database, private and public files, and then restore them on a freshly installed server. No more problems.

For what it’s worth, the previous install was one of my first installs of ERPNext, and I was confused about users, etc. It might be something to do with permissions at the OS level.

1 Like

Thanks for your update -

How to add socketio to start bench?

+1 even with latest versions as soon as one tries to setup a company and tries to upload a letterhead.

$ bench version
civil_contracting 1.5.0
erpnext 10.0.5
frappe 10.0.6
$ bench --version

Hello @rmehta,

I checked the Procfile.

Please what does this line do?
socketio: /usr/bin/node apps/frappe/socketio.js

The folder /node apps/ does not exist in my /usr/bin folder. Do i just point it to any socketio client js library?

Thank you.

same error, we change to Firefox and upload files ok!


I also had the same issue of “file upload disconnected. please try again”. after some try over and again i got one simple solution to this problem which helped me. you also can try may it help you " please check your file size and try uploading small size file you can try with size like 15 to 50KB of size and then upload" hope it help to get the answer to this issue.

it works for small size you can try with file GIF (Bitmap)~16.7 KB

1 Like