Folders not created for custom DocTypes

I have created a doctype inside the sales module, and I want to add the client side code. According to the manual for each doctype created via UI, I must have a structure of folders and files on disk, but in my case I do not see that this was created for the doctype that I indicated.
I am missing some step to create the folder and the files?
Thank you if anyone helps me.
Fernando Sánchez

Installed Apps
ERPNext: v9.x.x-develop (f76bc27) (develop)
Frappe Framework: v9.1.10 (master)


Hi, make sure you have developer_mode set in 1.

Completely sure

I think you must uncheck the “custom” field of the doctype.


For guys stuck at Folders not created for custom DocTypes when following this tutorial

My situation: I used Binami launch pad on GCP.
I active Developer mode to 1
But doc type directory structure didn’t show up as tutorials assumed.
So I open GCP VM Console (login as admin of VM) and add this commands
sudo chown daemon:daemon -R /opt/bitnami/apps/erpnext/htdocs/frappe-bench
then I reset apache by run
sudo /opt/bitnami/ restart apache
Doctype directory structure shows up as expected.
Hope you guys can save time from this painful issue

Try this command

bench migrate && bench build && bench clear-cache

Just ran into this. The DocType Directory Structure doc is a bit confusing.

After enabling developer mode on the site, refreshing the web page, and then creating and saving the new DocType (ensuring the Custom field is unchecked), the files will be in apps/myapp/myapp/myapp/doctype - one deeper than expected.

Maybe I am the only one who was confused like this.


This worked for me. Adding developer_mode 1 and unchecking the “custom” field of the doctype. Thanks

1 Like

This worked for me;
I Added developer_mode: 1 to the site_config.json file and unchecked the “custom” in the create doctype page

1 Like

Bro How?. my custom option beside 'is a child", “is submittable” is already unchecked.

What am i missing, i have added developer_mode: 1 to site_config.json.

but nothing shows up

Still dnt work

Thanks this solved my issue

This “chown” will make files “read only” for user bitnami.