Frappe V8.0.20 & later: socketio error

Recently @gvrvnk faced this issue,
Just reinstalled frappe and it worked!

Ran from frappe-bench and somehow it solved the problem

./env/bin/pip install -e apps/frappe

Hey revant, thanks for suggestion. Good to know someone else also faced this issue, lolz :stuck_out_tongue_winking_eye:

Tried reinstalling frappe, as suggested but didn’t work for me. But solved it by fresh install and restoring backup, so cheers!

I actually am experiencing the same issue as well. Doing this Frappe V8.0.20 & later: socketio error - #21 by revant_one doesnt help.

Still investigating but i get the feeling this error is appearing because of this PR, it is the only place that seems to specify the port 6787 New Build System using NodeJS by netchampfaris · Pull Request #3117 · frappe/frappe · GitHub

Am trying to hack at it to see what i can get, looking at the error it seems that whatever the script is doing, it is ignoring the URL and just merely substituting in the protocol as the URL. furthermore the server itself does not have port 6787 open so I am also kind of curious what is it actually that file_watcher_port is pointing to.

@netchampfaris, realized that it is your PR, any ideas why it behaves this way?

1 Like

Fixed via pull request #3232