Frappe-worker: ERROR (abnormal termination)

chandu@myerp:~/eipl/frappe-bench$ sudo supervisorctl restart
Error: restart requires a process name
restart Restart a process
restart :* Restart all processes in a group
restart Restart multiple processes or groups
restart all Restart all processes
Note: restart does not reread config files. For that, see reread and update.
chandu@myerp:~/eipl/frappe-bench$ restart all
restart: Unknown job: all
chandu@myerp:~/eipl/frappe-bench$ sudo supervisorctl restart all
frappe-web: stopped
frappe-worker: ERROR (abnormal termination)
frappe-web: started
frappe-workerbeat: ERROR (abnormal termination)

Check the log files in the frappe-bench/logs dir

Hi Pratik Vyas
This or my error logs for Bench.log for workerbeat.error.log

redis is not running
service redis start

hi pdvyas
chandu@myerp:~/eipl/frappe-bench$ service redis start
redis: unrecognized service

and i tried to reinstall Redis but crashes all the time.

Getting same issue, any solution?

Fixed processes for me:

sudo supervisorctl reread sudo supervisorctl update sudo supervisorctl restart all sudo supervisorctl status

Thanks a lot worked perfectly…