Hello , i Have been trying install ERPNEXT But i got error every time in mariadb

Hello , First im Happy to Been here .
i Have Been trying install Erpnext on ubuntu 20.4 localhost !
i Try Install.sh script but when i run it with sudo its import but stop after i run again it promote me mysql password & Administrator password i put them and nothing happen after that i ip.com &" but nothing appear .

i traid install by normal installing when i run command this guide

But when i run command : sudo mysql_secure_installation
i asked for some question my answer : none , Y.Y,Y,Y,Y
When i run command : bench new-site dcode.com
i got error Access is Denied Root@localhost Using Password : YES
Please Help !! thanks

Not to sure what you were doing. I do not recognize many of the commands you listed that you used.

However, yesterday I successfully installed a v13 system on a VPS server using this set of instructions:

The instructions do not use the easy install script. Instead, it is a manual method for installing the system that has been working for me for the past several months.

It may be helpful to read the entire thread, because some other users have also posted solutions to common problems found on some other linux images.

Hope this helps.


Thanks For your Replay ,
i Need to Setup it local not on vps
can u give me Guide to install , however i got problem in mariadb Access Denied root@localhost Password YES

im using ubuntu 20.4
Maraimdb 10.7
What u suggest Maybe ubuntu 20.4 have problem ?!
what the guide u followed !

I cannot help you with why you get eh Access Denied error with mariadb because I do not know how you installed it. Nor do I have time to try to figure out your install method.

I can only offer an alternate path to getting a working server. When I did it install yesterday I was using Ubuntu v20.04 because it is a LTS distribution now.


Good day @Mohamed-3tef

I had a quick look at your install method and have to go along with @bkm . I use yet a
third install method and have been able to install V13 reliably.

I can however comment on your answers at

But when i run command : sudo mysql_secure_installation
i asked for some question my answer : none , Y.Y,Y,Y,Y

The install method I use also asks me this as well and I have to enter a password.
This sounds inline with the error that you are getting. If you did not enter
a password, you will get “Access denied”.

Have a close look at the questions and make sure you answer them correctly ??

Good Day , Thanks For Your Answer ,
i will Try to fresh install and i will Post If i Got Error , so when i must answer with root password ?

  • and i must remove database test , and disallow remote ?
  • can u tell me the best practice to answer the questions
    thanks :slight_smile:

@Mohamed-3tef and @johnlongland Most likely the problem is that since Ubuntu 20.04 you cannot install ERPNext using the root mysql user. This is because sudo is required to login to mysql as root user.

Please see this thread for additional info

thanks For Your Replay ,
i installed Ubuntu 22.4 im going to fresh install i will add this step i will try i hope it work :slight_smile:

  • First Error :frowning:

Hello Again , Thanks for Sharing your setps
i Followed Yours

  • in sudo ls /etc/supervisor/conf.d : i found supervisor.config so i skip to the ‘enable scheduler’
  • i Did reboot the host .
    When i open ip host i got this still waiting for 4min nothing appear

    its normal ?! or there anything i need to do

Hello , Sorry for alot of asking
now its work but screen its has problem ! idk why

i run Command
“sudo cp ~/frappe-bench/config/supervisor.conf /etc/supervisor/conf.d/supervisor.conf”
and i Reboot the server but its same issue … im try to login but nothing ! its not saying if the password wrong !!
Can u Help me with that last step i guess
thanks again :slight_smile:

This is usually because the assets haven’t been built. run bench build

1 Like

Thanks Guys , i Reinstall Fresh installation And Now its Work on Port:8000
the problem was in setting Mysql ( Mariadb )
thanks :slight_smile:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.