How can I limit a user to a specific Warehouse?

For example, a Warehouse Officer is allowed to:

  • Receive, issue and transfer stock out of their warehouse.

Here’s where I can’t figure it out:

  1. a. How to restrict the user to only Transferring stock outwards.
  2. b. The user may be allowed to Submit Incoming Stock Transfers.
  3. The user is only allowed to make receipts (Purchase, Receipt, Material Receipt, Incoming Transfer etc) and issues for a given warehouse.

This is a common enough issue, someone should have solved it, yes?

1 Like

After check the forums thoroughly, found these two:

I’ll test these.

@rmehta is your update available to v10 users?

It does not appear that the “Warehouse” contains a user list any longer. It must have been taken out in some previous version. That usually means there is another method to do this. but like you, I have not yet found it.

Would user permissions be more appropriate for this requirement?

Probably. However, when you open that pandoras box in permissions, you are then going to have to supply user level permissions for everyone and for every task they may need permission to access.

It is hard enough to manage group level permissions without adding another level of complexity that is several times more intense.

If you have not started with user level permissions (at least in v10) from the beginning, then it will be significantly more difficult to set it up after you have already established much of your system without them. There always seems to be some process that was working before that you now have to revisit to figure out how to get the user permissions correct in order to get it working again. It can be done, but do you have the time to devote to it without impeding your regular day to day business?


@Duncan_Nkhata, @Obinna_Ukwueze

I’m not sure there’s an up-to-date community solution for this one yet. Let’s look into it

1 Like

Yes have you tried user permission?

1 Like

How can you use user permissions to restrict a user to an instance of a doctype?

Yes it’s diable else let me know

1 Like

User permissions worked guys, thanks!