How do you guys deploy your Frappe Personal Projects

Hey guys, I made a small begineer level basic project made with frappe and frappe-ui. But, I am not able to understand how to deploy it.

Can anyone please provide some information ? @buildwithhussain @shariquerik

1 Like

Hi :wave:

You can use any of the 2 approaches for deploying:

  1. Frappe Cloud: Click here, click there and done. More here.

  2. Self-host: You can rent a VM/server on the cloud and deploy it there. You can find the production setup guide here.


Frappe cloud frequently asks for payment method. I’m under aged so have no credit/debit card
Is there any guide available for deploying custom projects with Frappe Cloud ?

Tried migrating my site to frappe cloud site. I get the following error when trying both the command and python script.

As discussed in chat, you will need a private bench if you want to deploy a custom app.

1 Like

@buildwithhussain got a azure ubuntu 20.04 LTS vm. Installed all the dependencies. Earlier by mistake installed python3.8 but then after I came to know that frappe 14 needs python3.10. I quickly flushed 3.8 stuff and installed pyython3.10. But, after running bench init frappe-bench I get the following errors.

I tried applying fixes from How to upgrade to python 3.10 - #15 by Sagar_Patil but that didn’t help aswell

1 Like

It looks like the version didn’t get updated (in shell at least), try running python3 and checking the version of the REPL that opened up.

You could go with pyenv, which would make python version switches easier.


Ok installed pyenv.

So, now will I have to delete all the python versions from the system and install python3.10 specifically ? is this how it works ?

pyenv let’s you install multiple versions and switch between them easily. Just set the default to 3.10 or 3.11 and you should be good to go!

1 Like

ok lemme try

1 Like

Hey @buildwithhussain successfully setup done :raised_hands:. Very near to hosting my app.

I pushed my stuff to github. and tried installing it to the server frappe-bench dir. but the get-app command doesn’t work it says not found. I moved from app dir to root dir. But still the issue persists. Are there any ways, I can shift my projectfu app from local repository in my computer to the server computer ? SO, that I can just directly install the app on the server site

here’s the repo