How to install erpnext version 12 on ubuntu 18.04

Hi @Lucas_Moreira , Thanks for replying. For the user password, which part it is solving?

How to solve below installation error?

TASK [dns_caching : Add dnsmasq to network config] ******************************************************************************************************************************
task path: /tmp/.bench/playbooks/roles/dns_caching/tasks/main.yml:11
<> EXEC /bin/sh -c ‘echo ~root && sleep 0’
<> EXEC /bin/sh -c ‘( umask 77 && mkdir -p “echo /root/.ansible/tmp/ansible-tmp-1566961745.6961405-113787252108860” && echo ansible-tmp-1566961745.6961405-113787252108860=“echo /root/.ansible/tmp/ansible-tmp-1566961745.6961405-113787252108860” ) && sleep 0’
Using module file /usr/local/lib/python3.6/dist-packages/ansible/modules/files/
<> PUT /root/.ansible/tmp/ansible-local-5459hlf0qd1t/tmp0bovl9wv TO /root/.ansible/tmp/ansible-tmp-1566961745.6961405-113787252108860/
<> EXEC /bin/sh -c ‘chmod u+x /root/.ansible/tmp/ansible-tmp-1566961745.6961405-113787252108860/ /root/.ansible/tmp/ansible-tmp-1566961745.6961405-113787252108860/ && sleep 0’
<> EXEC /bin/sh -c ‘/usr/bin/python3 /root/.ansible/tmp/ansible-tmp-1566961745.6961405-113787252108860/ && sleep 0’
<> EXEC /bin/sh -c ‘rm -f -r /root/.ansible/tmp/ansible-tmp-1566961745.6961405-113787252108860/ > /dev/null 2>&1 && sleep 0’
ERROR! The requested handler ‘restart network manager’ was not found in either the main handlers list nor in the listening handlers list
Traceback (most recent call last):
File “”, line 413, in
File “”, line 135, in install_bench
run_playbook(‘site.yml’, sudo=True, extra_vars=extra_vars)
File “”, line 327, in run_playbook
success = subprocess.check_call(args, cwd=os.path.join(cwd, ‘playbooks’))
File “/usr/lib/python3.6/”, line 291, in check_call
subprocess.CalledProcessError: Command ‘[‘ansible-playbook’, ‘-c’, ‘local’, ‘site.yml’, ‘-vvvv’, ‘-e’, ‘@/tmp/extra_vars.json’, ‘–become’, ‘–become-user=myfrappe’]’ returned non-zero exit status 1.

rerun the installation and successful with below log

TASK [dns_caching : Add dnsmasq to network config] ******************************************************************************************************************************
task path: /tmp/.bench/playbooks/roles/dns_caching/tasks/main.yml:11
<> EXEC /bin/sh -c ‘echo ~root && sleep 0’
<> EXEC /bin/sh -c ‘( umask 77 && mkdir -p “echo /root/.ansible/tmp/ansible-tmp-1566962008.1090984-268896643148199” && echo ansible-tmp-1566962008.1090984-268896643148199=“echo /root/.ansible/tmp/ansible-tmp-1566962008.1090984-268896643148199” ) && sleep 0’
Using module file /usr/local/lib/python3.6/dist-packages/ansible/modules/files/
<> PUT /root/.ansible/tmp/ansible-local-26058q_agd9ji/tmpb9fo8aan TO /root/.ansible/tmp/ansible-tmp-1566962008.1090984-268896643148199/
<> EXEC /bin/sh -c ‘chmod u+x /root/.ansible/tmp/ansible-tmp-1566962008.1090984-268896643148199/ /root/.ansible/tmp/ansible-tmp-1566962008.1090984-268896643148199/ && sleep 0’
<> EXEC /bin/sh -c ‘/usr/bin/python3 /root/.ansible/tmp/ansible-tmp-1566962008.1090984-268896643148199/ && sleep 0’
<> EXEC /bin/sh -c ‘rm -f -r /root/.ansible/tmp/ansible-tmp-1566962008.1090984-268896643148199/ > /dev/null 2>&1 && sleep 0’
ok: [localhost] => {
“backup”: “”,
“changed”: false,
“diff”: [
“after”: “”,
“after_header”: “/etc/NetworkManager/NetworkManager.conf (content)”,
“before”: “”,
“before_header”: “/etc/NetworkManager/NetworkManager.conf (content)”
“after_header”: “/etc/NetworkManager/NetworkManager.conf (file attributes)”,
“before_header”: “/etc/NetworkManager/NetworkManager.conf (file attributes)”
“invocation”: {
“module_args”: {
“attributes”: null,
“backrefs”: false,
“backup”: false,
“content”: null,
“create”: false,
“delimiter”: null,
“dest”: “/etc/NetworkManager/NetworkManager.conf”,
“directory_mode”: null,
“firstmatch”: false,
“follow”: false,
“force”: null,
“group”: null,
“insertafter”: null,
“insertbefore”: null,
“line”: “dns=dnsmasq”,
“mode”: null,
“owner”: null,
“path”: “/etc/NetworkManager/NetworkManager.conf”,
“regexp”: “dns=”,
“remote_src”: null,
“selevel”: null,
“serole”: null,
“setype”: null,
“seuser”: null,
“src”: null,
“state”: “present”,
“unsafe_writes”: null,
“validate”: null
“msg”: “”

My errors were related with the fact that the script wasn’t authenticating with the provided password.
So every-time after I entered the Admin password for the data-base, etc, the script would crash. I realized later on that I had typed in the incorrect password so I changed it.

Installed beautifully on Ubuntu 18.04. However on bench update command got this error -

Traceback (most recent call last):
  File "/usr/local/bin/bench", line 11, in <module>
    load_entry_point('bench', 'console_scripts', 'bench')()
  File "/home/frappe/.bench/bench/", line 40, in cli
  File "/usr/lib/python3/dist-packages/click/", line 722, in __call__
    return self.main(*args, **kwargs)
  File "/usr/lib/python3/dist-packages/click/", line 697, in main
    rv = self.invoke(ctx)
  File "/usr/lib/python3/dist-packages/click/", line 1066, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/usr/lib/python3/dist-packages/click/", line 895, in invoke
    return ctx.invoke(self.callback, **ctx.params)
  File "/usr/lib/python3/dist-packages/click/", line 535, in invoke
    return callback(*args, **kwargs)
  File "/home/frappe/.bench/bench/commands/", line 32, in update'.')
  File "/home/frappe/.bench/bench/patches/", line 21, in run
    result = execute(bench_path)
  File "/home/frappe/.bench/bench/patches/v3/", line 7, in execute
    frappe_branch = get_current_branch('frappe', bench_path)
  File "/home/frappe/.bench/bench/", line 281, in get_current_branch
    return get_cmd_output("basename $(git symbolic-ref -q HEAD)", cwd=repo_dir)
  File "/home/frappe/.bench/bench/", line 370, in get_cmd_output
    output = subprocess.check_output(cmd, cwd=cwd, shell=True, stderr=subprocess.PIPE).strip()
  File "/usr/lib/python3.6/", line 356, in check_output
  File "/usr/lib/python3.6/", line 423, in run
    with Popen(*popenargs, **kwargs) as process:
  File "/usr/lib/python3.6/", line 729, in __init__
    restore_signals, start_new_session)
  File "/usr/lib/python3.6/", line 1364, in _execute_child
    raise child_exception_type(errno_num, err_msg, err_filename)
FileNotFoundError: [Errno 2] No such file or directory: './apps/frappe': './apps/frappe'

I have created a user by name frappe, but do I need to create a folder as well?

I had done easy install. There is no frappe user directory. So I am doing this from /home/frappe/site/erpnext

Thus the error.

I checked with a find command…there is no frappe-bench directory at all in my system. There is a frappe directory, though. Running bench update command from that directory produces the same error.

Unless you specified otherwise, frappe-bench is the default bench directory name for either Easy or Manual Install. One runs the bench command set from that directory.

Assuming you specified a frappe user account (as you say you did), that user account lives here /home/frappe. With a typical bench install, the frappe-bench is a subdirectory of that user account, hence the path to the bench is /home/frappe/frappe-bench.

When the install completes, the two apps erpnext and frappe live here
/home/frappe/frappe-bench/apps/erpnext and /home/frappe/frappe-bench/apps/frappe. Once you create a website - say site1.local, that you will find here /home/frappe/frappe-bench/sites/site1.local


Please advice, Is that package exist for Ubuntu 18.04?


apt install pyhton3-setuptools

results in,

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package pyhton3-setuptools


Might it be: python3-setuptools ?

Sorry, I can’t get you.

yes, this package doesn’t install unless it is available in such repository to be added first

Try changing phyton3 to python3, it could be a typographical error.

Ok thanks I got it,
I just copy that command from such guide

It stuck at here

PLAY [setup bench and dev environment] ****************************************************************************

TASK [Gathering Facts] ********************************************************************************************
task path: /tmp/.bench/playbooks/site.yml:40

The setps from 1 to 7 done

when i enter the command i am getting an error. bellow is the screenshot uploaded. Any input on this would be highly appreciated


1 Like

Show me the screenshot of command. Also, let me know if this installed for fresh machine. Its always recommend to install on fresh machine.

I am facing the exact same problem. I installed it on a fresh machine

1 Like

Hi Tufan,
i followed all the step, which is mention below.

  1. I have installed fresh Ubuntu 18.0.4LTS
  2. Ran the command apt-get update
  3. Ran the command apt-get upgrade
  4. Rebooted server
  5. apt-get install python3-setuptools python3-minimal redis-server build-essential
  6. created user erpnext

sudo adduser erpnext (Adding a new user erpnext)
usermod -aG sudo erpnext (giving proper permission)
su erpnext (login as erpnext user)

  1. Download the installation script by running below command:
  2. Then install the erpnext by using this command (it will take nearly 45 minits to run in 4GB virtualbox image, below command install all the requisite for erpnext (example nginx, mariadb etc ):sudo -H python3 --production --site localhost --user erpnext --mysql-root-password your_password --admin-password your_password --bench-name your_bench_name
  3. This will install the ERPNEXT. After this I have updated the bench by running below command:

cd erp_bench/
bench update

  1. I have accessed the application using the link http://localhost (It worked me from the port 80)

and after that

now i am facing the login error below is the screenshot attached kindly help me

Thanks in advance

Can you copy the text?