How to test v11? VM, Docker, Easy Install & even manual install producing errors on develop branch!

Hello community,

Me too excited for v11. Everyone is talking about that, and desperately looking to get it on my instance any one of these(VM, Docker, Easy Install, Manual install) but non of these working and continuously producing errors every-time. Even bench update is producing errors.

Everytime, I tried, error got changed, sometimes got installed successfully on hitting install commands twice-thrice.

Any help appreciated.

Well you’re not alone in this boat. I’ve been trying to deploy the develop branch for weeks but no success. I have tried every platform possible except of course which works fine…obviously.

1 Like

please share errors

did you make sure you had installed all prerequisites ?

My latest attempt which ended in failure is contained in this thread:

There’s another thread i opened when my attempt to install on a pc failed and there’s another i opened when my attempt to set up the downloaded VM failed.

Yes, I have done and played well with errors. Tried all basic prerequisite and noticing errors sometimes it’s redis, some time permissions, sometimes pip upgradation warnings and many more. Tried several time on fresh instance as well. Unfortunately, nothing worked.

The era when easy install works like charm. Now, nothing is working without errors. I know, there are huge changes in core and heavily refraction going on, doesn’t mean to affect installation process.

Anyone can update VM for develop? Or, share their machine ova?

1 Like

Please post specific traces.

The exact error below was experienced on GCP, Virtualbox VM and local machine fresh install using the easy install script:

TASK [bench : python3 bench init for develop] *********************************************************************
fatal: [localhost]: FAILED! => {“changed”: true, “cmd”: [“bench”, “init”, “/home/alvinetstore/frappe-bench”, “–fra
ppe-path”, “”, “–frappe-branch”, “develop”, “–python”, “python3”], “delta”: “0:01
:28.753495”, “end”: “2018-07-30 10:48:14.570820”, “msg”: “non-zero return code”, “rc”: 1, “start”: “2018-07-30 10:4
6:45.817325”, “stderr”: “INFO:bench.utils:virtualenv -q env -p /usr/bin/python3\nINFO:bench.utils:./env/bin/pip -q
install --upgrade pip==9.0.3\nINFO:bench.utils:./env/bin/pip -q install wheel\nINFO:bench.utils:./env/bin/pip -q in
stall six\nINFO:bench.utils:./env/bin/pip -q install -e git+ app frappe\nINFO:bench.utils:git clone GitHub - frappe/frappe: Low code web framework for real world applications, in Python and Javascript --branch develop -
-origin upstream\nCloning into ‘frappe’…\nwarning: unable to access ‘/home/alvinetstore/.config/git/attributes’:
Permission denied\ frappe\nINFO:bench.utils:/home/alvinetstore/frappe-bench/env/bin/pip i
nstall -q -e /home/alvinetstore/frappe-bench/apps/frappe --no-cache-dir\ app frappe_io\nINF
O:bench.utils:git clone GitHub - frappe/frappe_io: Website for Frappe --branch master --origin upstream\nCloning into ‘frapp
e_io’…\nwarning: unable to access ‘/home/alvinetstore/.config/git/attributes’: Permission denied\
installing frappe_io\nINFO:bench.utils:/home/alvinetstore/frappe-bench/env/bin/pip install -q -e /home/alvinetstor
e/frappe-bench/apps/frappe_io --no-cache-dir\nINFO:bench.utils:yarn install\nerror An unexpected error occurred: "
EACCES: permission denied, scandir ‘/home/alvinetstore/.config/yarn/link’”.\nTraceback (most recent call last):\n
File “/usr/local/bin/bench”, line 11, in \n load_entry_point(‘bench’, ‘console_scripts’, ‘bench’)()\n
File “/home/alvinetstore/.bench/bench/”, line 40, in cli\n bench_command()\n File “/usr/local/lib/py
thon2.7/dist-packages/click/”, line 722, in call\n return self.main(*args, **kwargs)\n File “/usr/
local/lib/python2.7/dist-packages/click/”, line 697, in main\n rv = self.invoke(ctx)\n File “/usr/loca
l/lib/python2.7/dist-packages/click/”, line 1066, in invoke\n return _process_result(sub_ctx.command.inv
oke(sub_ctx))\n File “/usr/local/lib/python2.7/dist-packages/click/”, line 895, in invoke\n return ctx
.invoke(self.callback, **ctx.params)\n File “/usr/local/lib/python2.7/dist-packages/click/”, line 535, in
invoke\n return callback(*args, **kwargs)\n File “/home/alvinetstore/.bench/bench/commands/”, line 30
, in init\n python \t\t = python)\n File “/home/alvinetstore/.bench/bench/”, line 83, in init\n up
date_node_packages(bench_path=path)\n File “/home/alvinetstore/.bench/bench/”, line 449, in update_node_packages\n update_yarn_packages(bench_path)\n File “/home/alvinetstore/.bench/bench/”, line 462, in u
pdate_yarn_packages\n exec_cmd(‘yarn install’, cwd=app_path)\n File “/home/alvinetstore/.bench/bench/
“, line 159, in exec_cmd\n raise CommandFailedError(cmd)\nbench.utils.CommandFailedError: yarn install”, “stderr
_lines”: [“INFO:bench.utils:virtualenv -q env -p /usr/bin/python3”, “INFO:bench.utils:./env/bin/pip -q install --up
grade pip==9.0.3”, “INFO:bench.utils:./env/bin/pip -q install wheel”, “INFO:bench.utils:./env/bin/pip -q install si
x”, “INFO:bench.utils:./env/bin/pip -q install -e git+”, “INF app frappe”, “INFO:bench.utils:git clone GitHub - frappe/frappe: Low code web framework for real world applications, in Python and Javascript --branch develop --o
rigin upstream”, “Cloning into ‘frappe’…”, “warning: unable to access ‘/home/alvinetstore/.config/git/attributes’
: Permission denied”, “ frappe”, “INFO:bench.utils:/home/alvinetstore/frappe-bench/env/bin
/pip install -q -e /home/alvinetstore/frappe-bench/apps/frappe --no-cache-dir”, “ app frappe
_io”, “INFO:bench.utils:git clone GitHub - frappe/frappe_io: Website for Frappe --branch master --origin upstream”, “Cloning
into ‘frappe_io’…”, “warning: unable to access ‘/home/alvinetstore/.config/git/attributes’: Permission denied”,
“ frappe_io”, “INFO:bench.utils:/home/alvinetstore/frappe-bench/env/bin/pip install -q -e
/home/alvinetstore/frappe-bench/apps/frappe_io --no-cache-dir”, “INFO:bench.utils:yarn install”, “error An unexpec
ted error occurred: “EACCES: permission denied, scandir ‘/home/alvinetstore/.config/yarn/link’”.”, “Traceback (mo
st recent call last):”, " File “/usr/local/bin/bench”, line 11, in “, " load_entry_point(‘bench’, ‘co
nsole_scripts’, ‘bench’)()”, " File “/home/alvinetstore/.bench/bench/”, line 40, in cli”, " bench_comma
nd()“, " File “/usr/local/lib/python2.7/dist-packages/click/”, line 722, in call”, " return self.m
ain(*args, **kwargs)“, " File “/usr/local/lib/python2.7/dist-packages/click/”, line 697, in main”, " r
v = self.invoke(ctx)“, " File “/usr/local/lib/python2.7/dist-packages/click/”, line 1066, in invoke”, "
return _process_result(sub_ctx.command.invoke(sub_ctx))“, " File “/usr/local/lib/python2.7/dist-packages/click/”, line 895, in invoke”, " return ctx.invoke(self.callback, **ctx.params)“, " File “/usr/local/lib/pyt
hon2.7/dist-packages/click/”, line 535, in invoke”, " return callback(*args, **kwargs)“, " File “/home
/alvinetstore/.bench/bench/commands/”, line 30, in init”, " python \t\t = python)“, " File “/home/alvi
netstore/.bench/bench/”, line 83, in init”, " update_node_packages(bench_path=path)“, " File “/home/a
lvinetstore/.bench/bench/”, line 449, in update_node_packages”, " update_yarn_packages(bench_path)“, "
File “/home/alvinetstore/.bench/bench/”, line 462, in update_yarn_packages”, " exec_cmd(‘yarn install
‘, cwd=app_path)“, " File “/home/alvinetstore/.bench/bench/”, line 159, in exec_cmd”, " raise Command
FailedError(cmd)", “bench.utils.CommandFailedError: yarn install”], “stdout”: “warning: unable to access ‘/home/alv
inetstore/.config/git/attributes’: Permission denied\nyarn install v1.9.2\ninfo If you think this is a bug, please
open a bug report with the information provided in “/home/alvinetstore/frappe-bench/apps/frappe/yarn-error.log”.
ninfo Visit yarn install | Yarn for documentation about this command.\n(‘installing’, u’frappe’
)\n(‘installing’, u’frappe_io’)\nUpdating node packages…”, “stdout_lines”: [“warning: unable to access ‘/home/alvinetstore/.config/git/attributes’: Permission denied”, “yarn install v1.9.2”, "info If you think this is a bug, ple
ase open a bug report with the information provided in "/home/alvinetstore/frappe-bench/apps/frappe/yarn-error.log
“.”, “info Visit yarn install | Yarn for documentation about this command.”, “(‘installing’, u
‘frappe’)”, “(‘installing’, u’frappe_io’)”, “Updating node packages…”]}
to retry, use: --limit @/tmp/.bench/playbooks/site.retry
PLAY RECAP ********************************************************************************************************
localhost : ok=44 changed=29 unreachable=0 failed=1
Traceback (most recent call last):
File “”, line 420, in
File “”, line 122, in install_bench
run_playbook(‘site.yml’, sudo=True, extra_vars=extra_vars)
File “”, line 338, in run_playbook
success = subprocess.check_call(args, cwd=os.path.join(cwd, ‘playbooks’))
File “/usr/lib/python2.7/”, line 541, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘[‘ansible-playbook’, ‘-c’, ‘local’, ‘site.yml’, ‘-e’, ‘@/tmp/extra_vars.jso
n’, ‘–become’, ‘–become-user=alvinetstore’]’ returned non-zero exit status 2

Using manual install on a fresh server on all these platforms installed successfully after several failed attempts due to prerequisites which had to be installed multiple times on some instances for the install to go past that stage. however, Bench start fails to start the instance as it gets stuck here in all cases:

15:02:45 socketio.1 | listening on *: 9000
15:02:55 web.1 | * Running on (Press CTRL+C to quit)
15:02:55 web.1 | * Restarting with inotify reloader
15:02:56 watch.1 | yarn run v1.9.2
15:02:56 watch.1 | $ node rollup/watch.js
15:02:56 web.1 | * Debugger is active!
15:02:57 web.1 | * Debugger PIN: 277-742-846
15:02:57 watch.1 |
15:02:57 watch.1 | Rollup Watcher Started
15:02:57 watch.1 |
15:02:57 watch.1 | Watching…
15:02:58 watch.1 | Rebuilding frappe-web.css
15:02:58 watch.1 | Rebuilding chat.js
15:03:00 watch.1 | Rebuilding frappe-web.min.js
15:03:03 watch.1 | Rebuilding control.min.js
15:03:06 watch.1 | Rebuilding dialog.min.js
15:03:06 watch.1 | Rebuilding desk.min.css
15:03:06 watch.1 | Rebuilding frappe-rtl.css
15:03:06 watch.1 | Rebuilding desk.min.js
15:03:11 watch.1 | Rebuilding module.min.css
15:03:11 watch.1 | Rebuilding form.min.css
15:03:11 watch.1 | Rebuilding form.min.js
15:03:12 watch.1 | Rebuilding list.min.css
15:03:12 watch.1 | Rebuilding list.min.js
15:03:13 watch.1 | Rebuilding report.min.css
15:03:13 watch.1 | Rebuilding report.min.js
15:03:16 watch.1 | Rebuilding web_form.min.js
15:03:17 watch.1 | Rebuilding web_form.css
15:03:17 watch.1 | Rebuilding print_format_v3.min.js
15:03:18 watch.1 | Rebuilding email.css
15:03:18 watch.1 | Rebuilding docs.js
15:03:21 watch.1 | Rebuilding erpnext.css
15:03:21 watch.1 | Rebuilding erpnext-web.min.js
15:03:21 watch.1 | Rebuilding erpnext.min.js
15:03:21 watch.1 | Rebuilding item-dashboard.min.js

Even the OVA downloaded fails to initialize as it gets stuck here as well. As some point i thought it was the hardware specs so for GCP i temporarily boosted my hardware to 4 CPU and allocated 8GB RAM to the instance but nothing changed.

1 Like

The initial error is due to permissions so you may need to ensure that you’re running as frappe user and perhaps also do a chown on that directory too to ensure its writable by your frappe user

Yes agreed both cases run afoul permissions so best to resolve that Fatal Error Installing ERPNext V11 Develop Branch on GCP Using Easy Install Script - #12 by clarkej