I have switched verison 13 to verison 14.but I am getting errror..Please help..how can i resolve this

Traceback (most recent call last):
File “/usr/local/bin/bench”, line 5, in
from bench.cli import cli
ModuleNotFoundError: No module named 'bench


It may help to say what steps you have taken to do the upgrade, and the command that resulted in the error message.

i have run these commands.and upgraded python version 3.8 to python 3.10.i have removed python3.8 folder directly from that path…local/lib/python3.10/site-packages
bench switch-to-branch version-14 frappe erpnext --upgrade
bench get-app --branch=version-14 erpnext
bench get-app --branch=version-14 frappe

Try: sudo pip3 install frappe-bench --upgrade
bench setup requirements

thanks but i am getting now that error when i run bench update.how can i reslove this…
…pymysql.err.OperationalError: (1045, "Access denied for user ‘_4ea0304f872’@‘localhost’ (using password: YES)

…please any solution …i am stuck.
ERROR 1045 (28000): Access denied for user ‘_4ea030d73’@‘localhost’ (using password: YES)

Please Try below command.

`mysql -u root -p`

After login, change the MariaDB authentication plugin with the following command:

MariaDB [(none)]>USE mysql; MariaDB [(none)]>UPDATE user SET plugin='mysql_native_password' WHERE User='root';

Next, flush the privileges and exit from the MariaDB shell with the following command:

MariaDB [(none)]> FLUSH PRIVILEGES; 
MariaDB [(none)]> EXIT;

thanks but …error is still there …it is not resolved …today i had run these commands.i think you will get idea …what i’m doing wrong…
1>mysql_install_db --user=mysql --basedir=/usr --datadir=/var/lib/mysql
2>sudo systemctl start mysqld
3>sudo systemctl start mysql.service
folder cleaned
cd /tmp
cd mysql

after this i am getting that error…all things am doing on live server…please give me precious advice

An upgrade does not usually disturb Mariadb/Mysql. Is there a backup of the database?

yes i have backup.and .i have not deleted site yet…if i delete then will lose all data of live server .what to do in this situation …server… I can’t open my tables using “SHOW TABLES;” command and getting the following error message.

MySQL Error #1046 (3D000) - No database selected

try bench --site <sitename> mariadb

stiil same:—erpnext@erp:~/frappe-bench$ bench --site erp.pkets.com mariadb
ERROR 1045 (28000): Access denied for user ‘_3ea03f873’@‘localhost’ (using password: YES

I would revert back to 13 and restore the database then attempt the upgrade to 14.

ie bench switch-to-branch version-13 frappe erpnext , then bench --site <sitename> --force restore <path.to.backup.sqz>

This may not work , but try it if you like. Difficult to know what state the dbms is in

If you do not mind this step then why not just install v14 and restore your backup? seems the only logical step to follow since you have faced difficulties with upgrading from v13. I faced errors too when trying to upgrade and i ended up just installing v14 and restoring by backup database.

1 Like

thanks,i have done this…but i am getting error.table does not exits
_4ea030d296e4f873.tabDocType State’ doesn’t exist"
(1146, "Table ‘_4ea030d296e4f873.tabSingles’ doesn’t exist

@ERP11 you have not installed bench under your current linux user.
because of that when you are trying to use bench, it results the mentioned error

follow this

@flexy2ky , Hi I have also faced many difficulties on upgrading v13 to v14.
So, Today I had a fresh installation of v14 and it worked great following this guide [Guide] How to install ERPNext v14 on Linux Ubuntu (step-by-step instructions)
After installation I have backed up my old v13 site database and restored on this new server and migrated the site. Every step shows “Success”. After the restoration no data like items, stock even Chart of Account is not showing any old data.
Please guide what can I do now?

yes i have installed but when i am running bench migrate .getting error

Executing erpnext.patches.v14_0.rename_ongoing_status_in_sla_document
AttributeError: ‘NoneType’ object has no attribute 'startswit
ModuleNotFoundError: No module named 'erpnext.setup.doctype.naming_series

ImportError: Module import failed for Naming Series, the DocType you’re trying to open might be deleted.
Error: No module named 'erpnext.setup.doctype.naming_series

ImportError: Module import failed for Naming Series, the DocType you’re trying to open might be deleted.
Error: No module named 'erpnext.setup.doctype.naming_series

bench --site your_site console
frappe.reload_doc('setup', 'doctype', 'naming_series')

then run

bench migrate