Installation Error / Permissions error

Is it only me or others are facing installation failed while using EASY INSTALLATION method on both ubuntu 14.04 and CENTOS 7

few days back I was able to install the using EASY INSTALLATION with and without root user and the site would work but I was not able to run bench update or any other bench command in the /frappe/frappe-bench folder, until I change the folder permissions to 0777 recursively. Even after that it would update but still with some errors.
if I ran any command as a root user it would say " you should not run this command as a root user"

Kindly help

@vjFaLk Any idea.

What easy installer are you using?

You should be running

python --production --user frappe

Also, once you finish the installation, to run any commands, you need to switch to the frappe user by doing su frappe. If you run the commands as root it won’t work properly.

It gets stuck here and then this error comes up

TASK [install bench] ***********************************************************
changed: [localhost]

TASK [Check whether bench exists] **********************************************
ok: [localhost]

TASK [init bench] **************************************************************
fatal: [localhost]: FAILED! => {“changed”: true, “cmd”: [“bench”, “init”, “/home /frappe/frappe-bench”, “–frappe-branch”, “master”], “delta”: “0:14:14.725267”, “end”: “2016-10-19 15:34:50.401842”, “failed”: true, “rc”: 1, “start”: “2016-10- 19 15:20:35.676575”, “stderr”: " app frappe\nCloning into ‘frappe’…\ frappe\n/home/frappe/frappe-bench/env/loc al/lib/python2.7/site-packages/pip/vendor/requests/packages/urllib3/util/ssl.p y:318: SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject N ame Indication) extension to TLS is not available on this platform. This may cau se the server to present an incorrect TLS certificate, which can cause validatio n failures. You can upgrade to a newer version of Python to solve this. For more information, see singwarning.\n SNIMissingWarning\n/home/frappe/frappe-bench/env/local/lib/pytho n2.7/site-packages/pip/vendor/requests/packages/urllib3/util/ Insec urePlatformWarning: A true SSLContext object is not available. This prevents url lib3 from configuring SSL appropriately and may cause certain SSL connections to fail. You can upgrade to a newer version of Python to solve this. For more info rmation, see Advanced Usage - urllib3 2.0.0a2 documentation tformwarning.\n InsecurePlatformWarning\nnum2words is in an unsupported or inva lid wheel\nTraceback (most recent call last):\n File "/usr/local/bin/bench", line 11, in \n load_entry_point(‘bench’, ‘console_scripts’, ‘bench’)( )\n File "/home/frappe/.bench/bench/", line 40, in cli\n bench_comma nd()\n File "/usr/local/lib/python2.7/dist-packages/click/", line 716, in call\n return self.main(*args, **kwargs)\n File "/usr/local/lib/pyt hon2.7/dist-packages/click/", line 696, in main\n rv = self.invoke(ct x)\n File "/usr/local/lib/python2.7/dist-packages/click/", line 1060, in invoke\n return _process_result(sub_ctx.command.invoke(sub_ctx))\n File \ “/usr/local/lib/python2.7/dist-packages/click/", line 889, in invoke\n return ctx.invoke(self.callback, **ctx.params)\n File "/usr/local/lib/python 2.7/dist-packages/click/", line 534, in invoke\n return callback(*arg s, **kwargs)\n File "/home/frappe/.bench/bench/commands/", line 19, in init\n verbose=verbose, clone_from=clone_from)\n File "/home/frappe/.bench /bench/", line 56, in init\n get_app(frappe_path, branch=frappe_bran ch, bench_path=path, build_asset_files=False, verbose=verbose)\n File "/home/f rappe/.bench/bench/", line 73, in get_app\n install_app(app=app_name, bench_path=bench_path, verbose=verbose)\n File "/home/frappe/.bench/bench/app. py", line 103, in install_app\n find_links=find_links))\n File "/home/frap pe/.bench/bench/", line 127, in exec_cmd\n raise CommandFailedError( cmd)\nbench.utils.CommandFailedError: /home/frappe/frappe-bench/env/bin/pip inst all -q -e /home/frappe/frappe-bench/apps/frappe”, “stdout”: “Already using inte rpreter /usr/bin/python\ninstalling frappe”, “stdout_lines”: [“Already using int erpreter /usr/bin/python”, “installing frappe”], “warnings”: []}
to retry, use: --limit @production/install.retry

PLAY RECAP *********************************************************************
localhost : ok=32 changed=20 unreachable=0 failed=1

Traceback (most recent call last):
File “”, line 351, in
File “”, line 111, in install_bench
run_playbook(‘production/install.yml’, sudo=True, extra_vars=extra_vars)
File “”, line 301, in run_playbook
success = subprocess.check_call(args, cwd=os.path.join(cwd, ‘playbooks’))
File “/usr/lib/python2.7/”, line 540, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘[‘ansible-playbook’, ‘-c’, ‘local’, ‘pro duction/install.yml’, ‘-e’, ‘@/tmp/extra_vars.json’, ‘–become’, ‘–become-user= frappe’]’ returned non-zero exit status 2

What OS and Version are you trying to install on?

@shreyasp, any ideas?

Does this seem to be the error?

ubuntu 14.04 server
also tried on CENTOS 7

it says “You can upgrade to a newer version of Python to solve this”. I am now going to try apt-get update and apt-get upgrade before running this setup. Do you think it may solve the issue?

The error I pasted is from ubuntu 14.04 lts server

Hm, lemme try running the setup on 14.04 and see if I’m having issues. What are you installing on? How much RAM does it have?

Xeon 2620 v4
20 GB ram

Thank you I appreciate your fast response.
can you can recommend me OS it works fine on

Ubuntu 14.04 and CentOS 7 should both work perfectly! I’m not sure why it’s breaking. I’ve made a Ubuntu 14.04 Droplet on DO and I’ll test the install, if it fails there is a problem in the installer that can be fixed, if not, there may be an issue with the install on your server.

The setup worked fine few days back. the only issue I had was that I couldnt run any commands that you told me to login as frappe and yes it worked.

It is from yesterday that the setup is not working

it might be related. “After the latest update”

The setup is working completely fine and without a single hitch on a DigitalOcean Ubuntu 14.04.05 Droplet. I’d suggest trying the latest Ubuntu 14.04? Or even 16.04 (You’ll have to install python-minimal using apt-get before running the installer)

1 Like

ok I have created a vm, ubuntu 16.04 now on esxi 6, will update you on results.

@vjFaLk It worked like a charm but after 1 failed attempt. What I did wrong was:

apt update and apt upgrade . must have messed up with unwanted versions.

Then I used your recommended way

  1. Fresh install ubuntu server 16.04 lts
  2. sudo su (to enter as root user)
  3. apt-get install python-minimal
  4. wget
  5. python --production --user frappe

This is all I had to do. Thank you for the struggle you did for me.


holy smokes…

Been trying to install on a fresh install ubuntu server 16.04 lts several times, and I get the same error as the first post

not running the apt update and apt upgrade as mentioned does solve the problem

Thank you

1 Like

@vjFaLk I followed the same step but getting below error

“Procfile does not exist or is not a file”

Thanks to this solution, I am now part of ERPNext…:grinning::smiley: