Installation error ubuntu 14.04 LTS

Hi, I was trying to set up erpnext on my local workstation. keep
getting errors while running the file, can you shed some light
on this?
When I run without sudo using this : ‘python --develop’, I get the following error:

Traceback (most recent call last):
File “”, line 342, in
File “”, line 8, in install_bench
File “”, line 122, in check_distribution_compatibility
if float(dist_version) in supported_dists[dist_name]:
ValueError: could not convert string to float: jessie/sid

And when I run with sudo I get an error long after some installation, I get this error:

TASK [setup procfile] **********************************************************
fatal: [localhost]: FAILED! => {“changed”: true, “cmd”: [“bench”, “setup”, “socketio”], “delta”: “0:00:15.022034”, “end”: “2016-09-07 14:13:16.457075”, “failed”: true, “rc”: 1, “start”: “2016-09-07 14:13:01.435041”, “stderr”: “npm ERR! Linux 3.13.0-95-generic\nnpm ERR! argv "/usr/local/bin/node" "/usr/local/bin/npm" "install" "" "redis" "express" "superagent" "cookie"\nnpm ERR! node v0.12.7\nnpm ERR! npm v2.11.3\nnpm ERR! path /home/tishad/.npm/cookie/0.3.1\nnpm ERR! code EACCES\nnpm ERR! errno -13\n\nnpm ERR! Error: EACCES, mkdir ‘/home/tishad/.npm/cookie/0.3.1’\nnpm ERR! at Error (native)\nnpm ERR! { [Error: EACCES, mkdir ‘/home/tishad/.npm/cookie/0.3.1’]\nnpm ERR! errno: -13,\nnpm ERR! code: ‘EACCES’,\nnpm ERR! path: ‘/home/tishad/.npm/cookie/0.3.1’ }\nnpm ERR! \nnpm ERR! Please try running this command again as root/Administrator.\n\nnpm ERR! Please include the following file with any support request:\nnpm ERR! /home/tishad/frappe-bench/npm-debug.log\nTraceback (most recent call last):\n File "/usr/local/bin/bench", line 11, in \n load_entry_point(‘bench’, ‘console_scripts’, ‘bench’)()\n File "/home/tishad/.bench/bench/", line 40, in cli\n bench_command()\n File "/usr/local/lib/python2.7/dist-packages/click/", line 716, in call\n return self.main(*args, **kwargs)\n File "/usr/local/lib/python2.7/dist-packages/click/", line 696, in main\n rv = self.invoke(ctx)\n File "/usr/local/lib/python2.7/dist-packages/click/", line 1060, in invoke\n return _process_result(sub_ctx.command.invoke(sub_ctx))\n File "/usr/local/lib/python2.7/dist-packages/click/", line 1060, in invoke\n return _process_result(sub_ctx.command.invoke(sub_ctx))\n File "/usr/local/lib/python2.7/dist-packages/click/", line 889, in invoke\n return ctx.invoke(self.callback, **ctx.params)\n File "/usr/local/lib/python2.7/dist-packages/click/", line 534, in invoke\n return callback(*args, **kwargs)\n File "/home/tishad/.bench/bench/commands/", line 98, in setup_socketio\n setup_socketio()\n File "/home/tishad/.bench/bench/", line 137, in setup_socketio\n exec_cmd("npm install redis express superagent cookie", cwd=bench_path)\n File "/home/tishad/.bench/bench/", line 127, in exec_cmd\n raise CommandFailedError(cmd)\nbench.utils.CommandFailedError: npm install redis express superagent cookie”, “stdout”: “”, “stdout_lines”: [], “warnings”: []}

PS: I am using a user other than root that has sudo access. I was trying to install following the instructions on the github page.

Thank you

Read this thread, might solve your issue.


There can be two possible reasons for this issue,

  1. Node installation on your machine was not properly done.
  2. Sometimes node repositories are not accessible, as it seems to be in this case, which causes the script to fail.

You can try re-running the install script or manually install the latest version of NodeJs on your machine.

Thanks to both of you. Will get back to you after I try your suggestions.

Deleted my node js installation, manually installed the latest version then re-ran the script. Still the same error. :frowning:

Did you try these 2 solutions also :grin:

These threads suggest the same things mentioned in your first reply. I tried going through them but no luck.