Installation woes - Ubuntu 18.04

OK, like many others I’ve tried (and failed) to get the easy install to work. I’ve tried many things but nothing seems to work so this morning I wiped my VM (VMWare ESXi 6.5) and re-installed Ubuntu 18.04LTS fresh from the ISO. I did the following, in this order:

as (local admin user jamesbooker):

apt-get update
apt-get upgrade
apt-get install python-minimal build-essential python-setuptools

added a new user (frappe):

adduser frappe
usermod -aG sudo frappe

(still as local admin user jamesbooker)

wget (github install script)
sudo python --production --user frappe

The install took a LONG time, but it seems to have gone through OK.

The next step of the guide at github then says ‘for production, follow [setup production link]’

So i go through to the setup production page, and tried the simple command :-

sudo bench setup production
Usage: bench setup production [OPTIONS] USER

Error: Missing argument “user”.

First problem is you need to specify a user (not specified in the docs on the setup production page) so I try the following command:

sudo bench setup production frappe

I have tried this command as both the local admin user which installed frappe in the first place (jamesbooker) and by logging in as the (frappe) user. In both instances, python crashes out with:

FileNotFoundError: [Errno 2] No such file or directory: ‘./config/supervisor/conf’

So the ‘Easy Production Setup’ doesn’t work out of the box, so I decided to try the manual setup, and the very first command fails with the same FileNotFound error as above. This happens whether I am logged in as (jamesbooker) or (frappe)

Cna anyone give a definitive answer as to how to get past this step?


May have found a solution in this post:

However, there is a correction further down the page as a space was missed before --user

Just flashed my VM again, will update with results

So ture. Word keeps on combining – into - thus the paste here is erroneous. Thank you for the correction.

I tried your method, @Tufan_Kaynak2 and have exactly the same problem when trying ‘sudo bench setup production’ - even when trying ‘sudo -H bench setup production frappe’ - any ideas?

Well, it appears I don’t need to do the bench setup production - that’s already done by the easy install script, it’s just poor documentation

I will give you a thread to follow,


Thank you @nmami i got it working just a couple of hours before your post, but it will be helpful to others who come across this thread

The documentation is in dire need of update

Great, meanwhile do you have something to add on top of what I share with you in the note? As lessons learned like that I can consolidate a note and shared for all in one place…

Nope, I basically did exactly what you said, I just figured it out for myself before your post that’s all

1 Like