Issue with "developer mode" in version v12.x.x-develop () (develop)


We’re in the process of evaluating Frappe to help build out some of our backoffice operations. This framework looks like an excellent candidate for our requirements, as it covers both non technical contribution from accounting staff to design the models, relationships and their UI and then hand over to an in house development team to work on the more complex business logic. We were able, at first glance, to get it up and running pretty easily.

However, we simply have not been able to get it working in “developer mode”, or make the “Developer” application widgets appear, logged in as either Administrator or a high-privilege user. We have followed the tutorial to the letter, (up to and until the “Doctype” section), also adding the “developer_mode”: 1 setting to the “site_config.json” and flushing the cache / restarting the bench. We even put debugging code in the main codebase to identify that the application WAS in developer mode. Additionally, we have tried this with both postgres 12 (our ideal scenario) and MariaDb 10.4.13. Can anybody identify what we might be doing wrong or might have left out? When googling about we noticed that this has happened numerous times in the past, but none of the solutions posted seemed to work for us.

The environment/requirements installed are as follows:
VirtualBox 6.1.6 VMs (we have also tried on an AWS EC2 T3 w/2GB RAM with exactly the same effects)
Ubuntu 18.04
Python 3.6.9
Node v12.18.0
npm 6.14.4
yarn 1.22.4
MariaDb 10.4.13 / PostGres 12.3

Although the application boots up and runs without any visible problems, we also see this every time a “bench” command is run:

WARN: bench is installed in editable mode!
This is not the recommended mode of installation for production. Instead, install the package from PyPI with: `pip install frappe-bench`

Screenshots of desktop attached

What is your main query here or what is it you’re trying to achieve?

If it’s about adding the shortcuts to the desk , check this post:

Hi Kenneth,

Thanks for the reply. No, it was about setting up and progressing through the tutorials presented on the website. We solved it in our session yesterday. The track that describes discovering where the Developer application is in the tutorial is replaced in the “Customizations” area, selecting the “Doctype” action. After creating the doctypes in this way, we were able to proceed with the tutorial.

On an aside, is there any further Frappe Framework material (besides the standard documentation) you can point us to that can help kickstarting a multi-tier application? We believe that Frappe hits the correct mix that will allow our less-technical treasury staff to participate with one of our development teams to deliver a critical app very quickly. Something like a “nexts steps” or a “Frappe cookbook” of particular best practices?



Additionally, for those whom MariaDB is not an option, we are prototyping it with PostGres 12, and we have seen no problems so far


Good to know. We use PG for some of our other applications and we’re interested in this. Please do share your steps here

Still having problems getting the Module to appear in the sidebar, or in the main desktop card areas. We can assign doctypes to shortcuts with no problems, but there seems to be a bit of an issue handling the library manager module as a whole. We followed the instructions here, to no avail:

Additionally, there seems to be a problem in displaying linked fields in the “Quick Edit” dialog. The fields do populate in the “Edit in full page” screen: