Login screen does not show after database restore and update

Hi all, i’m really frustated by now. i have my erpnext running on CentOS 8, got preinstalled by ionos.
After i restore our former database and run an update everything seems to work fine for maybe a day or two. But after that i can’t see the login form on the login page.
Output from the Chrome Console is:

Failed to load resource: the server responded with a status of 404 ()
jquery.min.js:1 Failed to load resource: the server responded with a status of 404 ()
format.js:19 Uncaught ReferenceError: jQuery is not defined
at format.js:19
at socketio_client.js:237
bootstrap.bundle.js:120 Uncaught TypeError: Cannot read property ‘fn’ of undefined
at bootstrap.bundle.js:120
at bootstrap.bundle.js:7
at bootstrap.bundle.js:7
at bootstrap-4.js:58
shopping_cart.js:62 Uncaught ReferenceError: $ is not defined
at shopping_cart.js:62
at shopping_cart.js:186
jquery.min.js:1 GET https://erp.hardt2.com/assets/frappe/js/lib/jquery/jquery.min.js

Could somebody please help me to figure out the problem and solve it?

Thank you very much in advance! :slight_smile:

Try bench build

1 Like

After restoration of db I always do bech migrate and bench clear-cache

I’ve got a similar issue, I get the website page but no login page. I’ve tried all forms of updating, bench update --patch; bench migrate; bench clear-cache etc… This is what I see:


I Tried bench migrate/clear cache and bench build swell. But it’s still not working.

Is there a way to do a backup and then reinstall? I have data in the system which I’d not like to get rid of

That worked for me. But unfortunately the login screen also vanished after 2 days or so

Ok, I’ve located the problem area: @nextchamp.saqib @rohit_w with a few other contributors have added a new module for Italian taxes, and I used to use the module of Massimo Corvino called erpnext_fattura_elettronica. So I believe that there is some serious issue in the reconciliation of the data based on the old code with the new one. since I don’t see any update utility nor do I see any suggestions. Does anyone have any ideas? Thanks a lot. Do I have to reinstall stuff or is there some way to recover the old ERP data?

Thank you.

@nextchamp.saqib @rohit_w do you have any insights on the changes in the Italian electronic invoicing changes in the new version?

Thank you,

Same problem here. did you guys find a solution ? cause ?