Making Auto Attendance work

Please also check all the Pre-requisites for Auto Attendance to work:L

  1. Define the Default shift on employee or define the shift assignment for the employee.
  2. Tick the auto attendance on Shift Type and configure the parameters.

Also check out on the Employee Checkin details that Shift is assigned automatically at the time of registering employee checkin.

I have done every thing according to the instructions but still failed to get auto attendance marked

I may be misunderstanding. For example, if Last Sync is 1 January 2023 17:00, then only the attendance prior to that time/date will be processed, correct?

Is this something that needs to be changed daily?

I have yet to be able to get auto-attendance to work. I have all the prerequisite settings correct with shift assignments, etc.

1 Like

Yes, that is correct.

You can setup in biometric sync utility to update this field daily automatic. Alternatively you can create server script to update the field daily.

1 Like

I am new to ERPNext, so I am not sure how to write a script to do this. We do not have biometrics so employee’s check in/out manually every day.

You may look at a potential solution i have marked here : After Upgrading V14, I am getting Pop Up Time this week must be in format: HH:mm:ss on Shift Shift Type

Hello @kartik ,
i have followed the guide by this article, mostly from @kartik,

i have checkins at May. why i can’t see the attendance based on these days’s checkins.

i have two types of shift, morning and afternoon, both are assigned to employee HRM.

Based on the screenshots, the check-in times are different from the shift setup.
People can check-in from 12:30 pm - 7:00pm and any check-ins between these times will be considered.
Also first entry will be treated as IN type and the next one will be treated as OUT type based on the option selected in "Determine Check-in and Checkout" field.

Dear @kartik,
thank you! i followed your guide as shown in my screenshot:
i have two shift, morning(9:00-12:30) and afternoon(13:30-18:00),the morning shift setting is same as afternoon beside start and end time.
i imported new checkin from June first to third, as the order of in followed by out.

i thought it the background job is not working, so i checked the logs, found it was executed.

even though, i doubt it might not get inside the function of process_auto_attendance, so i put one log to find out, after i put below log, somehow the job is not working, i did not see the log above anymore.
that is really confused me. i did not know where i went wrong.

Did you assigned the shifts to employee before importing check in data ?

Please open the check in data and check that shift is marked on the record.


@mangroliya, thank you for your response, yes, i did.


If you assigned the shift correctly, on check in details it should pick the shift like below:

Based on this shift system is marking attendance.


Dear @mangroliya,
thank you for point that out, yes, my check in details does not show the shift field as you marked, i checked the shift assignment, it was assigned to HRM, why HRM’s checkin does not have the shift field?

where i went wrong?

Dear @mangroliya,
good day, i finnally figure out why my checkins don’t have shift field, they are all imported via a csv files, when i mannually add one shift, the filed shows up. this bring me why can’t import checkins?

during the mannually add checkins, i encountered antoehr problem, our morning shift out time is 12:30, when i add out checkin after 12:30, it was automatically assigned to afternoon shift’s checkin? it should be morning check out, because my morning shift time end at 12:30

1 Like

hello everyone,
please somebody help here, still not making auto attendance working,

i did everything according to this article.
1, create shifts(moring and afternoon)–>enable auto attendence-> assign to a employee;
2, add checkins.

Is your issue resolved yet?

Can you search for the Scheduled Job Type doctype and check the status of this background job?

If it has failed, share the traceback. Also, what version are you using?

Dear Rucha Mahabal,
Thank you for your reply, it suddenly worked at day 19th June. i did not change anything. don’t know why?

Attendance marking depends on the Last Sync of Checkin. If your last sync of checkin is being updated then the attendance should function fine. More details here:

How to automatically Attend for a shift without pressing the “Mark Attendance” button during that shift?

Checkin my staff here

Sorry, i’m a newbie. Help me, thanks. Best regards!