Maximum call stack size exceeded libs.min.js:9922

Sent invitation

We have pushed a fix to avoid the recursion.


@nabinhait @max_morais_dmm

Still not resolved, guys. I’ve left a note on GitHub as well. The problem with Domain selection seems solved. But the calendar date-picker is still broken, as of 30 minutes ago.

Hi, can you specify your timezone so that we can try to replicate. It’s working fine for Brazil’s timezone and ours.

Let’s forget about my local install, let’s just focus on

  1. Launch the demo
  2. Click on Accounts
  3. Click on “General Ledger”
  4. At the top of your form are parameters for dates.
  5. Try typing in 4/30/2017, then hit tab. A different, random date is entered. Bug #1
  6. Try clicking inside. This opens the calendar pop-up. Click “Today”, then tab out. A random date is entered. Bug #2.
  7. Click inside, the calendar pops up. Select any date you want. Some other, random date is entered.

If you inspect Console while doing this, you’ll see the recursion error messages.

I can duplicate this from Firefox, Chromium, and Opera on various different machines, both Linux and Windows. So it should have nothing to do with my local environments.

Now, this same exact thing happens on my local install. But again, let’s not worry about that. Much easier to consider, which should be a known entity.

And even though it totally shouldn’t matter, I’m US Pacific time zone. :sunglasses:

1 Like

Actually this bit is the most important one.
Earlier, I was not able to replicate the issue even on, so I tried changing my timezone to Brazil, and could replicate the issue.

Changing the time zone on your operating system? Or somewhere with the application?

I have an installation on MacPro (Host) and VirtualBox VM and I’m using Eastern Standard Time for Host and Americas/Toronto for Erpnext settings.
Still problems with data picker same as @brian_pond.

Please share the time zone set on your operating system

When tested from a browser on Windows 10, the time zone is “Pacific Standard Time(GMT-08:00) Pacific Time (US and Canada)

When tested from a browser on my Ubuntu system, the contents of /etc/timezone is America/Los_Angeles

I’ve tried all of the timezones mentioned. Still not able to replicate.
Need more information to replicate.

Can you try and replicate the issue by setting your timezone to GMT +05:30 ??

This will determine if it is really a timezone problem

Can’t replicate the issue neither with GMT +05:30 nor with GMT +08:00 on

When I changed to GMT +05:30, the issue disappeared. I tested several times, and the calendar and dates worked perfectly.

Then I changed back to GMT minus 08:00. And the issue came back. The user interface was also noticeably slower. Which makes sense, because of the recursion error message, these would use up time and reduce responsiveness.

So it’s definitely a timezone problem.

1 Like

Hi. I have the same problem whit date picker from general ledger my time zone on erpnext local install is set to america/cancun or east time gmt -6. But I have noticed that on general balance form the date picker and account filters works properly. I use windows 8 as host and vm ubuntu 16.10. I have noticed too that this error appears after an automatic update of my system, this update broke my data base too. I have to realize a bench migrate to reestablish my database but date picker error appear after this. There is a pacht for this problem? I’m new on erpnext. Please help.