[Mega Thread] Version 12 Release Bugs

Anyone else having this issue and their production system down since yesterday by any chance?

try installing software-properties-common & dirmngr before doing python install.py

try pip install PyYAML==3.13

Stuck here

Not able to login

run update again…

Still the same

Getting this error
bench.utils.CommandFailedError: yarn install

Mobile version UI bug: Module cards are way too easy to drag which makes it extremely hard to scroll the screen.

My suggestion: Users should hold and drag the module card, just like any mobile apps in android…


git config remote.upstream.fetch “+refs/heads/:refs/remotes/upstream/
git fetch upstream

The star character is removed during posting! Please be advised and careful!


Always pre-format the text to keep some of the special characters.

What are these errors and warnings up to? are they zombie package references? How to mitigate these? Why the upgrade script is not handling them?

Just a reminder for the developer/code masters…

Does not solve anything as the other versions still exist and Erpnext script cannot detect the existence of a correct version.

1 Like

thanks for that …
git config remote.upstream.fetch "+refs/heads/*:refs/remotes/upstream/*"

with custom apps atop the core, V11 to 12 updates on our staging env. are not happening inspite of all the local changes being in sync with the repo…, even did not get thru with the local apps removed…v10 to 11 did not have any such major issues and so that’s live in our prod. server…

Issues opening varius doctypes including invoices, quotations, etc.
“Invalid field name: compact_item_print”

Anyone else experiencing anything similar?

Hi. I am trying to integrate ERP with LDAP. It works for a single Organizational Unit. Are Multiple OU options available in V12?

I just noticed that the last breadcrumb for every doctype leads to settings. Example below is an employee doctype and the breadcrumb leads back to settings, whereas it is supposed to lead me back either to Employee List or Human Resources:

I have noticed it in all doctypes visited so far since i upgraded to V12. This was not the case with previous versions. Can this be looked into and corrected?

When I login (Chrome) it is a blank screen. I need to reload by clearing browsers and ERP cache. This is a recurring issue. Please let me know if there is anything else needed to troubleshoot.

Installed Apps
ERPNext: v12.0.1 (version-12)

Frappe Framework: v12.0.1 (version-12)

After updated to 12, i found that the " Desktop " cannot scroll as usually in " Mobile App & Touch Screen Windows "

it is dragging my module list instead of scrolling down.

how to settle this ?

please advise… THANKS!!!~~



Did you tried on the very left or right side on the Screen? On IOS IT works.