ModuleNotFound 'frappe' after update to 13

I am using the prod VM. I successfully updated to 12.90. I updated to 13 after changing the branch. I am now getting the error I mentioned. I have tried several things to fix it, and at this point I do not know where I am at, what a hot mess!!

Can you post the complete error? VM upgrade from 12 to 13 is a huge mess which I went through once. May be I could help.

Yes, I will post later today.

So I tried to do a bench update and this is the error I get.

Not the screenshot. Copy paste the error here.

I started over with a fresh production VM from ERPNext. I am now getting the message there is a update for Frappe and ERPNext. What are my steps to do the update. I am going to take a snapshot this time!

@Touseef Do you have instructions for performing the 13 update??

Hi @mtuma5672,

Please check this topic:

Thank You!


Were you able to upgrade successfully? If not let me know. I could provide the steps I did for upgrading.

I did not upgrade yet. I would greatly appreciate instructions for upgrading my VM!
Thank you!

OK. I will do so shortly. But I cannot guarantee it would work 100% as it was done long time ago. Probably upgraded to V13.11 I guess. Now it is V13.23 so not sure if the steps would be relevant.

My previous steps were failing today to upgrade from V12 to V13. But I tried new steps and could upgrade successfully. Here are the steps

cd frappe-bench
sudo apt-get install python3.7
sudo apt-get install python3.7-dev
bench migrate-env python3.7

sudo python3 -m pip install --upgrade pip
sudo -H python3 -m pip install --upgrade setuptools cryptography psutil
sudo -H pip install ansible

sudo -H pip3 install --upgrade frappe-bench

curl -sL -o
sudo bash
sudo apt install nodejs
sudo npm install -g yarn

Just to make sure the home directory have sufficient permissions to run the below command. Replace “frappe” with your user. my user did not have enough permissions so was getting error for bench setup requirements
sudo chown frappe -R /home/frappe
bench setup requirements

bench switch-to-branch version-13 frappe erpnext --upgrade
bench update --patch 

The entire process took almost 70-80 minutes. So be patient :slightly_smiling_face: