Nginx fail to start after encrypt domain on gcp

Dear Team, anyone have any clue?

1 Like

Hello my guess is this symbolic link is missing:

frappe@ubuntu:~/frappe-bench$ ls -al /etc/nginx/conf.d/frappe-bench.conf 
lrwxrwxrwx 1 root root 43 Mar 20  2018 /etc/nginx/conf.d/frappe-bench.conf -> /home/frappe/frappe-bench/config/nginx.conf

Here’s how to restore that [solution] 'supervisorctl start all' has no response or affect - #2 by clarkej

A forum search on this “configuration file /etc/nginx/nginx.conf test failed” will land you more case pointers.

One other request tip - to copy and paste the problem traceback adds to the forum search ‘inventory’ - an snapshot image is not text searchable! - and also means no need to manually enter fussy search string paths to browse code and the forum…

keep in mind.

Thank your Sir,

1 Like

Invalid value in /etc/nginx/conf.d/frappe-bench.conf:155

? - fix config error, and then
sudo systemctl enable nginx && sudo systemctl restart nginx

Thank you very much team for such suggestions

I have just created a new instance. The old instance is deleted. Many people will suffer from such a problem. But I will take another trip to confirm the given suggestion and confirm it so that it will work for someone.

The error is quite specific and has been documented here before. After letsencrypt install, you have to change this line in nginx.conf
ssl_protocols TLSv1.2 TLSv1.3;


ssl_protocols TLSv1 TLSv1.1 TLSv1.2;

Then nginx will start again.


Yes exactly, Nginx fail to start on Ubuntu 16.04, Google Cloud Platform after applying SSL.

sanath@vmi322735:~/frappe-bench$ sudo service nginx start
Job for nginx.service failed because the control process exited with error code.
See “systemctl status nginx.service” and “journalctl -xe” for details.

your solution worked for me.