No letterhead in Quotation via Email

Can somebody please help me out with the following issues regarding the attached PDF in Email:

  1. Letterhead to be used for the document.
  2. The Quotation always has one extra blank page.
  3. The date from print format builder changes its position from the right side, to the left side of the page in the PDF in Email.

None of these are an issue in the print menu.

Thanks in advance!

@rmehta Any suggestions?


Assuming that this is your own setup, this could be an installation issue.

Say the url you use to access your site is “http://localhost:8000”, then run this command:

bench --site site1.local set_config hostname "http://localhost:8000"

where site1.local is the folder name of your site in frappe-bench/sites folder


Hi @anand

Thanks for your reply!

I ran the command, but it didn’t return anything, although the letterhead issue did get fixed! The extra blank page still remains.

Also, is there any way of having the letterhead repeat every page?

Thank you so much!


Yeah letter head does not auto-repeat unless the page break happens at the item table level. This is a missing feature. Can you raise an issue on github?

I am not sure about the blank page


Thanks, will do!

Running brand new bench v2? on ubuntu 14.04

I am having the same issue with pdf not showing the letter head and a second page getting generated. I have tried running the suggested commands but get errors. Kind of wish the rest of this thread did not get moved to github anyway my errors are below

NOTE i have this in my sites/ file as i am trying to get https going

“host_name”: “”,
“ssl_certificate”: “/etc/letsencrypt/live/”,
“ssl_certificate_key”: “/etc/letsencrypt/live/”


bench --site set_config hostname “

Usage: bench frappe [OPTIONS] COMMAND [ARGS]…

Error: No such command “set_config”.
root@erp-2:/home/frappe/frappe-bench/sites/ bench frappe --site set_config hostname “
frappe app is not installed. Run the following command to install frappe
bench get-app frappe GitHub - frappe/frappe: Low code web framework for real world applications, in Python and Javascript
Traceback (most recent call last):
File “/usr/local/bin/bench”, line 9, in
load_entry_point(‘bench==0.0.0’, ‘console_scripts’, ‘bench’)()
File “/home/frappe/bench-repo/bench/”, line 20, in cli
return old_frappe_cli()
File “/home/frappe/bench-repo/bench/”, line 78, in old_frappe_cli
os.execv(f, [f] + sys.argv[2:])
OSError: [Errno 2] No such file or directory

I’m having this same issue with PDFs generated as attached emails. Running my own server and updated to the latest version. Does anyone have a solution?

We update today to last version and have same problem , when i print as PDF or send quite by email , don’t show letter head .
any one have solution ?

I am having the same issue after updating to the latest version.
The letterhead is not showing in the PDF not only for quotation, but also for sales invoice, purchase orders and other same documents… Anyone, please share your solutions. Thank you…

I have a similar problem i have seemingly successfully moved a erpnext site to an new server
… however i have the exact same issue with no letterhead, some strange formatting, and an extra page in my pdfs
i have this in my ~/frappe-bench/sites/site1.local$ vi site_config.json

“db_name”: “secret”,
“db_password”: “secret”,
“host_name”: “”,
“hostname”: “

NOTE host_name and hostname not sure which is correct depends on which post you read around here

I can see things fine in the browser and even use firefox to print to pdf but no images in erpnext generated pdf or email.

just little adjustment. command needs to be

bench --site site1.local set-config hostname "http://localhost:8000"

set-config instead of set_config

1 Like

set-config not set_config

Usage: bench  set-config [OPTIONS] KEY VALUE

  Insert/Update a value in site_config.json

  -g, --global  Set Global Site Config
  --help        Show this message and exit.