No luck using Easy Install Ubuntu 16.04 and 18.04

Good Day,

Before using ubuntu 16 i installed ErpNext v11 using Easy install but now for the v12 cant do it again i saw different discussion here about the error using easy install and i also tried the command they gave but still cant install erpnext v12… also read the official page for easy install.

any suggestion please for the step by step , I’m evaluating now the odoo and want to try the v12 of ErpNext but still no luck using EASY Install

if there is need to install first or disabled in ubuntu system… etc to make easy install work?

Thank you

More Power ErpNext

Where u r stuck?

Hi @sinichi19
Try manual installation. Use these steps:

Thank you

after i gave the mysql password and admin password
cant recall exact error but i remembered there is network manager…

already deleted my vm no logs save sorry

will try this tomorrow thank you sir
will give you feedback once done

Repeat again and take notes every steps, take screenshots for errors and post it here someone from community will help you


Noted Sir will try again tommorow i read some post of error and there are same error i encountered but when i tried the solution command still cant install hehehe

I also thinking now to try using centOS but i more familiar using ubuntu hehe :slight_smile:

Sir @nmami below is the command i used and the error i encountered during easy install
any idea? thank you sir

Ubuntu 18.04 fresh install

sudo apt-get update
apt-get upgrade

apt-get install python3-minimal build-essential python3-setuptools

adduser testuser

usermod -aG sudo testuser

su test user

export LC_ALL=C.UTF-8


sudo python3 --production --user testuser

(gave mysql password and admin password)


[WARNING]: No inventory was parsed, only implicit localhost is available
[WARNING]: provided hosts list is empty, only localhost is available. Note
that the implicit localhost does not match ‘all’
[WARNING]: Could not find aptitude. Using apt-get instead
[WARNING]: Consider using the get_url or uri module rather than running
‘curl’. If you need to use command because get_url or uri is insufficient you
can add ‘warn: false’ to this command task or set ‘command_warnings=False’ in
ansible.cfg to get rid of this message.
ERROR! The requested handler ‘restart network manager’ was not found in either the main handlers list nor in the listening handlers list
Traceback (most recent call last):
File “”, line 414, in
File “”, line 230, in install_bench
run_playbook(‘site.yml’, sudo=True, extra_vars=extra_vars)
File “”, line 351, in run_playbook
success = subprocess.check_call(args, cwd=os.path.join(cwd, ‘playbooks’), stdout=log_stream, stderr=sys.stderr)
File “/usr/lib/python3.6/”, line 311, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘[‘ansible-playbook’, ‘-c’, ‘local’, ‘site.yml’, ‘-vvvv’, ‘-e’, ‘@/tmp/extra_vars.json’, ‘–become’, ‘–become-user=testuser’]’ returned non-zero exit status 1.

use this steps here, it’s better to start from fresh server

Sir @nmami already installed using Easy Install and setup nginx

bench setup nginx
sudo ln -s pwd/config/nginx.conf /etc/nginx/conf.d/frappe-bench.con

but when i browse
We will be back soon.

try to run bench update and all are ok but same problem


cd ${HOME/}frappe-bench
./env/bin/pip install werkzeug==0.16.0

1 Like


1 Like

I just used the easy install script and didn’t face any error while installing, however, setup wizard is not loading. Page showing we will be back soon.

use this guide @flexy2ky hope it helps too