No Permission to save report


Since upgrading to Version 8 on one of our systems, we notice that we are not able to create or save any reports. Even after setting up developer mode option, and logging in with administrator login, we are getting this error while trying to create or save a report. “No Permission to save report”.

Any idea what could be the issue?


Somehow, I tried setting up Role Permission for Page and Report etc… and I am able to create and save reports now. But, moving forward, will this have to be done every time? Or, is it just a one time setup?


i am having the same issue… below is the screenshot.

Hi @ai_me,

Did you check all the permissions? Somehow, when I just checked all the settings over there and then selected report and checked the System Manager in the Role Manager for Pages and Reports, it allowed me to create and save the report. Just check those settings out.


Below is the screenshot.

Just ensure that you have set developer mode on with

bench set-config developer_mode 1

Then, also check Role Permission for Page and Report inside Setup.
There, select Report in Set Role for option
Select the report name
And, then, choose the System Manager role inside Allow Roles.

Well, this is what I did and it worked.

1 Like

Hi @UmaG, thanks… let me check on that… :slight_smile:

you need to be in Administrator account and make sure to be in developer mode

Hi, i have the same problem. I create topic

Does anyone raise a github issue?

Hi @vladucoju,

Looks like this is due to the role and permission setup that has been introduced for each report. Following these steps should help:

  1. Check “Role Permission for Page and Report” option inside Setup.
  2. There, select Report in Set Role for option
  3. Select the report name
  4. And, then, choose the System Manager role inside Allow Roles. (If your role is system manager. Change accordingly as per your role).

Refresh the page and the report should work.

1 Like

I follow your explanation but still nothing. Definitely is some bug, because before update everything was ok.

Just add role Report Manager to enable saving the Reports as well as Report Automail

I’m receiving the same error -

user system manager has role system manager -

I’ve restarted and checked

Got it working but works only for admin account?

User with Report Manager role only can save report

1 Like

@hereabdulla only admin is working not report manager role

I can confirm this behaviour (ERPNext version 8.7.0)

  • even with correctly set rights in the roles, System Manager cannot create nor change/save reports


  • set “developer_mode”: 1 (e.g. in /sites/site1.local/site_config.conf)
  • bench restart
  • log in as Administrator