Not able to run the application after installing the application freshly

I have issue in running the freshly installed expnext application. I tried to debug a issue by running the command - sudo supervisorctl status all

I found below services are not running.

erpnext-workers:erpnext-frappe-schedule: ERROR (no such file)
erpnext-workers:erpnext-frappe-default-worker-0: ERROR (no such file)
erpnext-workers:erpnext-frappe-long-worker-0: ERROR (no such file)
erpnext-workers:erpnext-frappe-short-worker-0: ERROR (no such file)

I tried to manually restart. But no luck it end up with same above error.

Greatly apricate, if somebody can help me to resolve this issue.


Can you share the traceback screen?
Perhaps the ports are already in use

Thanks for immediate response. I installed the application in virtual environment inside VM.

Down you can see the complete result of running the status command. When I tried to connect to the application from browser the error is site not found.

(erpnext) ayyappan@ubuntu:~/erpnext/erpnext$ sudo supervisorctl status all
erpnext-redis:erpnext-redis-cache RUNNING pid 10397, uptime 0:03:43
erpnext-redis:erpnext-redis-queue RUNNING pid 10396, uptime 0:03:43
erpnext-redis:erpnext-redis-socketio RUNNING pid 10398, uptime 0:03:43
erpnext-web:erpnext-frappe-web RUNNING pid 10403, uptime 0:03:43
erpnext-web:erpnext-node-socketio RUNNING pid 10399, uptime 0:03:43
erpnext-workers:erpnext-frappe-default-worker-0 FATAL can’t find command ‘None’
erpnext-workers:erpnext-frappe-long-worker-0 FATAL can’t find command ‘None’
erpnext-workers:erpnext-frappe-schedule FATAL can’t find command ‘None’
erpnext-workers:erpnext-frappe-short-worker-0 FATAL can’t find command ‘None’


There is a problem with your worker threads
Check that your ~/frappe-bench/config/supervisor.conf is correctly formulated

cat ~/frappe-bench/config/supervisor.conf

and then share the last few lines from [group:frappe-bench-workers] onwards

You can also try the option recommended here… which is

echo fs.inotify.max_user_watches=524288 | sudo tee -a /etc/sysctl.conf && sudo sysctl -p
bench restart

Hi trentmu

Please find the details below asked for:-

[group:{{ bench_name }}-web]
programs={{ bench_name }}-frappe-web {%- if node -%} ,{{ bench_name }}-node-socketio {%- endif%}

{% if use_rq %}

[group:{{ bench_name }}-workers]
programs={{ bench_name }}-frappe-schedule,{{ bench_name }}-frappe-default-worker,{{ bench_name }}-frappe-short-worker,{{ bench_name }}-frappe-long-worker

{% else %}

[group:{{ bench_name }}-workers]
programs={{ bench_name }}-frappe-workerbeat,{{ bench_name }}-frappe-worker,{{ bench_name }}-frappe-longjob-worker,{{ bench_name }}-frappe-async-worker

{% endif %}

[group:{{ bench_name }}-redis]
programs={{ bench_name }}-redis-cache,{{ bench_name }}-redis-queue {%- if frappe_version > 5 -%} ,{{ bench_name }}-redis-socketio {%- endif %}


I have resolved this issue by reinstalling my VM.

I had tryton which is an another erp application installed in my VM. Some of the services used by tryton had clashing with this application. I’m guessing that could be the issue.

1 Like