PDF Email Problems Thread

Hi airzoink,

It worked fine!

Thanks! :slight_smile:

Hi ai_me, this worked in my local installation:

Hi neginy, this worked fine in my local installation.

No more problems with the letterhead / format. I can now see images properly. I still have this message you’re refering to, I’m looking for a way to delete the link to the “message”.

I add host name but still not work and same issue , : check bellow my config file :

“db_password”: “SDsdfgg43348h”,
“db_name”: “Sgji892Lj”,
“hostname”: “”,
“nginx_port”: 7005

i try bellow also but not work :

“db_password”: “SDsdfgg43348h”,
“db_name”: “Sgji892Lj”,
“hostname”: “”,
“nginx_port”: 7005

some one know what’s issue ?

Hi rtimagine,

I got mine working with:

“host_name”: “http://myip”,

Hope this helps!

Kind regards,


I find problem i use “hostname”: “”, i change to “host_name”: “”, and problem solve .
now looking how i can remove "View this in your browser" and “Leave this conversation:” ??
Because it’s linked to local ip and server and when we send email to customer it’s not work for them .


I have managed to migrate my site to a new server to try and resolve some ongoing problems i have with pdfs attached to emails however it is still not solved.

The problem now being, PDF does not show header or product images, formatting is wrong, all the text is justified left and there is an extra page. There are some posts by me and others about this or similar problems which do not seem to help me and some seem abondoned/outdated or not solved.

In order to keep this post short and sweet i am not going to list all the posts that i have researched regarding this issue, instead i would just like to mention that i have a freshly migrated system and have run the below commands;

bench --site site1.local set-config hostname “bil-1.mydomain.com
and checked that “hostname”: “bil-1.mydomain.com” was in my site1.local/site_config.json

I have also run bench use bil-1.mydomain.com

neither of which seem to fix my issue also the link in my email is wrong and still points to site1.local instead of bil-1.mydomain.com

NOTE: print format appears correctly and when i press the PDF button the PDF gets generated correctly, only the pdfs attached to emails are broken right now

Thanks in advance

I know i am replying to myself here, but i noticed all images in the pdf attached to the email are little squares … so probably a link issues same as the incorrect link at the bottom of the email

I obviously need this to work … as i am not sure where to begin where do i find the errors relating to this? where do i find the logs? anything need some hints … please !

seems that it has to be host_name, not hostname.

That actually seems to have made things worse or maybe just different now i get no images even when try to generate a pdf when i use the pdf button. Which works fine with hostname

Also now that i am using host_name email pdf attachment still has no images, and the link is still wrong not site1.local anymore but kind of a weird mix of my email server and erpnext server twice like this

https://my,email.server/server/bil-1.mydomain.com/bil-1.mydomain.com/Sales Invoice/SINV-00018?format=Standard&key=09ed48dc02f19e22c0b2868d4284ee5e81370dde93bbd392bcf62bf7

I don’t suppose putting a slash at the end of the host name url fixes anything?

I’m still having issues letterheads missing with emailed pdf’s, although pagination, layout, and generation through browser work perfectly fine.

Nope no change with a “/” added to the end of host_name also i have alignment and an extra page as well as no letterhead

Before changing to host_name it was the same as you describe above
" pagination, layout, and generation through browser work perfectly fine. "

@c0mputerking @superlack I have combined these threads and pinned them to the ERPNext section until June 30th. Hopefully consolidating these will make finding the information easier.

I also deleted a few posts which didn’t contribute to the conversation.

@s.ilter In the future, try to edit your posts to fix the images, instead of replying.


I installed latest version VM. Now when I try to send an order by email the pdf print don’t have any logo and layout of the document is totally messed-up.
If I just printout this same document there is no issue with it.
You can find both files attached.
Please help me to solve this issue.

Thanks in advance and regards,

Incorrectly Formatted Emailed PDF:

Correctly Formatted PDF:

Dear all,

I managed to solve this issue, please find below how I did, please make note my install is VM version 221215:

  1. in your shell type cd frappe-bench/sites/erpnext.vm
  2. nano site_config.son
  3. add by typing “host_name”: “http://localhost:xxxx” between {…} which I had only db_password" and “db_name” and no “host_name”
  4. save it and woila!



i have two issue.

  1. Getting pdf format is not aligned.all content move to left.
  2. When i’m tried to send mail with pdf attachment it takes too much time to process.



May I know ERPNext version you are working on? If not latest, please upgrade and then check again.

Sceenshot indicating alignment issue in the PDF format will be helpful.

Thanks Umair,

I’m using V4. how do i upgrade to latest version.

PDF generation takes a lot of processing power. What are your machine specs?