Print and PDF Having Grey Table Borders

Hi All,

I am having a problem, I cannot seem to get Black border for the tables, I created a print format from scratch using HTML, Created one using Print format Builder, even used the standard print format and it all has grey lines.

The printers I have are dot matrix printers, as the lines are grey it doesn’t print lines, in V4 it was fine using standard print formats. I even tried it on Laser printers, the lines are always grey.

You can use printer driver’s “Print as Black” option

Thanks for the quick response.

I just checked for the option, It does not exist on the dot matrix printer, I did look for it on the laser printer as its a black and white printer its not there too.

Is there anything else that I could have missed?

You will have to google for your printer model on how to change color to black and white

I checked for the printers there is no extra settings to print only in Black and White as they are black and white printers.

Any Idea why the PDF generated have the same issue, It seems to come there too…

I found the solution to the problem. When I was tinkering with the Print Format Settings, I added extra code into the Custom CSS box and this fixed the problem of the borders coming in grey. Now it prints the tables with borders on the dot matrix printer.

I wanted to know for the formats for which I use the Print Format Builder can I add custom CSS, I tried it it doesn’t respond, I have a feeling its because I am not specifying the right elements, where can I see all the CSS elements the Print Format Builder is using?

Also by doing this will I break the code, or prevent the system from updating? :smile:

Thanks for all the help so far

Hi @bibinqcs,

I have the same problem as yours while trying to print the delivery note and sales invoice to dot matrix printer (Epson LX-310). Can you share the CSS code that you use to solve the grey table borders?

Much Appreciated,


I used the CSS code below, it produces black borders on a dot matrix printer. The printer is a Epson LQ-590

border:1px solid black;

I hope this helps

You may also try changing “Print Style” in print settings.