Setup Failed: Could not start up: Error in setup

@golfergamer retry until it works i have done it 5 times retry

Observed the same issue in a vanilla Debian 9 / Python 3 / ERPNext V12 --develop instance.

Had applied Setup Wizard: Could not start up: Error in setup - #2 by lasalesi

And then basically just clicked retry - retry - retry - retry (4x) then a background worker error came up but it went through…

why do we need to retry. Is there any technical explanation to this somewhere?

cd frappe-bench
bench switch-to-branch master
bench update --patch

This solved the issue for me without multiple tries

My observation:

  • in completing setup, several processes (and data writing) need to be done.
  • somehow in the middle, the process can take too long a time, or simply just got broken.
  • so the process stop and notify as failed.
  • when retrying, the process starts over, but since the previous process has done (or the data has been written), those process just ignored (or bypassed). And the process continue with the next.
  • do this retry several times, and finally the whole process (and data) is completed.
  • now you get that: “…and finally it works” :grinning: which actually (maybe) it does work from the beginning but the process que just gets in the way.

I don’t know what happen behind the screen, but that is just my observation. So maybe the “updates” need to handle those queing process?

Thank you.

1 Like

Exactly it’s work after 10 retry retry…;
I found on the logs that issues where detected on the modification of *.cpython-35.pyc, where * is any module; And after retry, the file is not the same…As @rahy said it seems like the retry correct the file…
Thanks to all

1 Like

A simple trick I learned, Start the process as production then after you set up, go back to dev.

bench start --no-dev

My speculation is that frappe pre-builds things perfectly when using production.


Thank you my good man. It works perfectly.

Thanks worked!!