Site Name and FQDN

I just completed the installation (finally, whew).

I am not by any way an expert on this stuff, so I apologize if this is a simple question.

My server has a dedicated IP address. My idea was to use a ddns for the end users to use instead of the naked IP address. I have the ddns setup to point to the IP address using a Type A record. The URL is

I setup the etc/hosts to be mazars

The hostname of the server to be mazars in /etc/hostname

I did bench new-site erpnext.mazars.ddns dot net.

Now that the installation is completed, now what? I typed in erpnext.mazars.ddns dot net and it says: “erpnext.mazars.ddns dot net’s DNS address could not be found. Diagnosing the problem. DNS_PROBE_POSSIBLE”

I also tried mazars.ddns dot net:8000. I am sure it is obvious I am doing something wrong, so I appreciate some guidance. Thank you in advance.

(Sorry I had to replace the period with the word “dot” as it counted those as links, to which I can only post 2)

Do you know you can get a name like from namecheap for $2.50 a year?

You can also get a free account on cloudflare that provides you with an HTTPS face to the world, with a disguised IP address, so you can be seen as … while running from your own server.

Cloudflare handles stuff like denial of service attacks and keeping your static pages up, live and usable while your server is offline completely.


Thank you for the suggestions. Once I get the settings to work and can test the ERP, I will look into these two options, because I do like what you say.

But even with these two options, how do I setup my server to be accessed?

Why do you need to use a ddns when you have a dedicated static ip?

Did you run bench setup nginx and sudo bench setup production $sitename

Now, I logged into the server, and all the folders are not there anymore. I will reinstall and try again.

I following the tutorial on YouTube: How to Install Step By Step ERPNext on Ubuntu 20.04 || frappe || Erpnext || Tamil || Linux || ubuntu - YouTube

It did not include your two command: “sudo bench setup production $sitename”

Also, I had to do “Bench Start”. Then I got the login screen. Thanks for all your help!

Make certain your site name exactly matches the domain name you wish to use:

├── Procfile
      :      :      :      :
├── sites
│   └──

So,, must match :


must match: