SMS alert configuration

Remove Sender parameter
And make sure you enter international dialing code on mobile no you’re sending to.
Your receiver parameter is wrong. It should be just ’ message ’
And receiver parameter should be just ’ mobile’

Can you please post a latest screenshot showing what have you entered in SMS Settings?

Please see the latest screenshot. I have removed password.


SMS Settings

SMS Center

SMS Settings should be:

Message Parameter: message
Receiver Parameter: mobile

And from static parameters table, remove 3rd row which is for sender. If you want you can mention sender name in the left side “SMS Sender Name” field. But it must be a short name, generally less than 8 characters (verify with your service providers).

Now below is the latest settings but still no success.

I did try using its working greate :slight_smile: see my post SMSBlastr another way to send SMS alert using your own phone

1 Like

Thanks for help. I have created account as per instructions and tried to send message but its is not received at receiver end, when erpnext shows message is sent to the number.

Please look at the screen shots of sms settings, sms center and smsblastr, & guide me.

Note:- I have not loaded any credit balance, assuming free sms initially.


1 Like

Can you screenshot the menu Phone Workers? I think your phone it not online or not activated

When using your last screen grab is nearly correct.
SMS gateway URL is correct - message
Message Parameter is correct - mobile
You should leave SMS Sender Name empty.
Static URL Parameters:
Your username is probably your email address. It is what ever you log into with. Probably Not your phone number.
Your password is whatever you log into with.

Now re-read my post carefully and see if it works.

SMS Gateway URL
For single SMS:
For bulk SMS:

Message Parameter: message
Receiver Parameter: mobile
SMS Sender Name: Leave Empty - Leave Blank - Don’t Put Anything Here

Enter Static Parameters:
Parameter: username Value: Your sendpk username/email address
Parameter: password Value: Your sendpk password
Parameter: sender Value: Your Company Name


Please find the screenshot attached.

Looks OK. Can you screen shoot the smsblastr app in your phone.

When I click on SMSBlastr icon, it shows following info.

Msg Daily (sent/quota):0/500
Msg Monthly (sent/quota):0/6000
Message Queued:4


[Stop service]

[Log out]

Can you try to tap the stop then start the service button.

I have notice your mobile number is so long. It that’s normal? :slight_smile:

Thanks bro!

I have stopped service and restarted but still same status. Messages go into queue.
Secondly my phone no is ok. It actually contains country code,network code and phone no.


Surprisingly, I have received 3 messages (blocked in queue) on my receiving number right now. it means settings are ok.

Thanks a lot.


1 Like

nice :slight_smile:

1 Like

Thank you very much ccfiel and others as well supporting me.


Thanks, now sendpk configuration is also working.:slight_smile:

1 Like

@Zahid.Butt how to set SMS trigger Points as like email alert.