[Tutorial] How To install ERPNext V12 on windows 10 home / Pro WSL ubuntu 18.04LTS

There’s two potential causes for this and I don’t remember how I solved it.

  1. Some underlying package of cryptography has a problem with WSL
  2. It could be isolated to the frappe-bench’s virtual environment. This one is easier to solve, so try it first: bench pip install cryptography

This is the error. Kindly anyone guide please
frappe@DESKTOP-GD56773:~$ sudo -H python3 install.py --production --site frappe.local --user frappe
Logs are saved under /tmp/logs/easy-install__2021-04-09__12-14.log
Checking System Compatibility…
ubuntu 18 is compatible!
curl already installed!
wget already installed!
git already installed!
Installing pip3…
pip3 installed!
Command “python setup.py egg_info” failed with error code 1 in /tmp/pip-build-j0f6tr7d/cryptography/
Traceback (most recent call last):
File “install.py”, line 436, in
File “install.py”, line 143, in install_prerequisites
‘python3’: “sudo -H python3 -m pip install --upgrade setuptools cryptography ansible==2.8.5 pip”
File “install.py”, line 118, in run_os_command
returncode = subprocess.check_call(command, shell=True, stdout=log_stream, stderr=sys.stderr)
File “/usr/lib/python3.6/subprocess.py”, line 311, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘sudo -H python3 -m pip install --upgrade setuptools cryptography ansible==2.8.5 pip’ returned non-zero exit status 1.

getting the same error…

You cannot install a production ERPNext site to WSL because it relies on systemd, which is not available in WSL distributions.

I think one of the problems is within the script, the location of playbooks is at ‘/tmp/.bench/bench/playbooks’ and not ‘/tmp/.bench/playbooks’

hi @nmami sir,

i want to install ERPNEXT in my windows 10, I download virtual box and am not able to download production.ova file what can i do sir. please help

My understanding os that ova is production ERPNext. There is no ova for develop branch

@Nihar this note describe something different from your question unfortunately.

Am I to understand each services need to be manually started every time Windows boots? Is there no way to make them start automatically?